Is there a way to cap fps in Sandbox editor? (CRYENGINE 5.4)

#1
As per title.

What i have done is append the following lines:

;custom
r_VSync=0
sys_MaxFPS=60

at the editor.cfg, autoexec.cfg and system.cfg files in \CRYENGINE Launcher\Crytek\CRYENGINE_5.4 AND in \CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64 where the editor and sandbox executables are located. However it doesn't work.

Frame rate is always capped when going in game. Is there a method to do that in the editor?

Thanks in advance.

Re: Is there a way to cap fps in Sandbox editor? (CRYENGINE 5.4)

#2
Hi,

r_VSync and sys_MaxFPS only work in game mode.

Here a flowgraph I have made in the past you can test it with.

Code: Select all

<Graph Description="" Group="FG"> <Nodes> <Node Id="40" Class="Debug:InputKey" pos="-684,2430,0"> <Inputs entityId="0" Key="p" NonDevMode="0"/> </Node> <Node Id="41" Class="Debug:InputKey" pos="-1152,2736,0"> <Inputs entityId="0" Key="o" NonDevMode="0"/> </Node> <Node Id="46" Class="Debug:ExecuteString" pos="-144,2286,0"> <Inputs String="r_VSync 1" NextFrame="0"/> </Node> <Node Id="48" Class="Debug:DisplayMessage" pos="522,2538,0"> <Inputs entityId="0" message="" DisplayTime="0" posX="50" posY="50" fontSize="2" clr_Color="1,1,1" centered="0"/> </Node> <Node Id="50" Class="String:SetString" pos="-144,2358,0"> <Inputs In="Vsync on"/> </Node> <Node Id="52" Class="Logic:Any" pos="198,2556,0" InHideMask="1023" OutHideMask="1"> <Inputs /> </Node> <Node Id="53" Class="String:SetString" pos="-144,2574,0"> <Inputs In="Vsync off"/> </Node> <Node Id="54" Class="String:SetString" pos="-180,2808,0"> <Inputs In=""/> </Node> <Node Id="57" Class="Debug:ExecuteString" pos="-144,2502,0"> <Inputs String="r_VSync 0" NextFrame="0"/> </Node> <Node Id="63" Class="Logic:Sequentializer" pos="-414,2448,0" InHideMask="63" OutHideMask="1023"> <Inputs Closed="0" Reverse="0"/> </Node> <Node Id="67" Class="Debug:ExecuteString" pos="-180,2736,0"> <Inputs String="" NextFrame="0"/> </Node> <Node Id="69" Class="String:Concat" pos="-468,2736,0"> <Inputs String1="sys_MaxFPS " String2=""/> </Node> <Node Id="73" Class="Math:Calculate" pos="-684,2736,0"> <Inputs Op="0" A="10" B="0"/> </Node> <Node Id="75" Class="Math:Counter" pos="-864,2754,0"> <Inputs max="0"/> </Node> <Node Id="76" Name="VSync_and_FPS_test" Class="_commentbox" pos="-1170,2212.5146,0"> <Inputs TextSize="1" Color="0.27451,0.352941,0.705882" DisplayFilled="1" DisplayBox="1" SortPriority="16"/> <ResizeBorder X="0" Y="0" Width="2016" Height="612"/> <NodeSize Width="2016" Height="667.48676"/> </Node> <Node Id="77" Name="Turn_VSync_on/off" Class="_comment" pos="-414,2430,0"/> <Node Id="78" Name="Increase_FPS_with_every_button_press" Class="_comment" pos="-666,2682,0"/> </Nodes> <Edges> <Edge nodeIn="63" nodeOut="40" portIn="In" portOut="Pressed" enabled="1"/> <Edge nodeIn="75" nodeOut="41" portIn="in" portOut="Pressed" enabled="1"/> <Edge nodeIn="52" nodeOut="50" portIn="in1" portOut="Out" enabled="1"/> <Edge nodeIn="48" nodeOut="52" portIn="Show" portOut="out" enabled="1"/> <Edge nodeIn="48" nodeOut="52" portIn="message" portOut="out" enabled="1"/> <Edge nodeIn="52" nodeOut="53" portIn="in2" portOut="Out" enabled="1"/> <Edge nodeIn="52" nodeOut="54" portIn="in3" portOut="Out" enabled="1"/> <Edge nodeIn="46" nodeOut="63" portIn="Set" portOut="Out1" enabled="1"/> <Edge nodeIn="50" nodeOut="63" portIn="Set" portOut="Out1" enabled="1"/> <Edge nodeIn="53" nodeOut="63" portIn="Set" portOut="Out2" enabled="1"/> <Edge nodeIn="57" nodeOut="63" portIn="Set" portOut="Out2" enabled="1"/> <Edge nodeIn="54" nodeOut="69" portIn="In" portOut="Out" enabled="1"/> <Edge nodeIn="54" nodeOut="69" portIn="Set" portOut="Out" enabled="1"/> <Edge nodeIn="67" nodeOut="69" portIn="Set" portOut="Out" enabled="1"/> <Edge nodeIn="67" nodeOut="69" portIn="String" portOut="Out" enabled="1"/> <Edge nodeIn="69" nodeOut="73" portIn="Set" portOut="out" enabled="1"/> <Edge nodeIn="69" nodeOut="73" portIn="String2" portOut="out" enabled="1"/> <Edge nodeIn="73" nodeOut="75" portIn="B" portOut="count" enabled="1"/> <Edge nodeIn="73" nodeOut="75" portIn="DoCalc" portOut="count" enabled="1"/> </Edges> </Graph>
However there is 2 things you still can do.

Workaround:
You can limit the FPS with for example NVIDIA Inspector.
If you press on the settings icon and go to the "Sync and Refresh" tab you can change the "Frame Rate Limiter" settings.

Or you may want to look into this pull request:
https://github.com/CRYTEK/CRYENGINE/pull/50

Who is online

Users browsing this forum: No registered users and 0 guests