Error purchasing membership!

Hey, I decided to purchase a base membership but run into an error when checking out. The error message I get is "Ordered component does not belong to ordered plan group."

The steps I take are:

1. Click "Subscribe now" under base membership
2. Click "Proceed to checkout."
3. Fill out all required fields in next window "Account Details." Check "I agree...." box. I'd also note that this box doesn't appear in chrome. Click "Save and continue" and that's when I get the error.

I tried this in Edge, Chrome, and Firefox, in incognito modes, on two different computers, also on my phone. Same error every time. I also contacted support yesterday @ but haven't heard back. It would be really nice to get this fix/solved by the weekend.

Re: Error purchasing membership!

Hey there, sorry to hear you are having trouble purchasing a membership plan on Please contact our support team at contact[at] via email and they'll fiy it for you immediatelly.


Thanks for getting to me here Nic. It's been a week now and last I heard from the support team was last Thursday. I'm really frustrated because I don't think this should be taking more than a week to resolve.

Re: Error purchasing membership!

Hey Quasar,

thanks for your inquiry. It is my understanding that your issue has been fixed and that you were able to purchase a membership. To avoid future issues, please don't use a VPN when trying to puchase anything from the, that includes the Marketplace and Memberships.

Thanks and welcome to the INSIDERS club! =)
CRYENGINE Brand Manager

I'm manning the CRYENGINE stations on Facebook & Twitter as well, so come and say hi!
My personal Twittering may contain nuts.

Get to know me.

Who is online

Users browsing this forum: No registered users and 0 guests