Not getting "release" files after compiling CryEngine

#1
Hi,
After compiling the Cryengine with Visual Studio I'm not getting the files I need for the game in the "Release" folder as you can see here below.
I've compiled the engine first with "Debug" and then with "Release" in Visual Studio.
And here is my folders after compilation:
release.png
release.png (44.08 KiB) Viewed 7928 times
x64.png
x64.png (120.86 KiB) Viewed 7928 times

What is happening? Can you help please?

Re: Not getting "release" files after compiling CryEngine

#4
It is the state of the CMake scripts during 5.4.
All binaries output in any configuration go into the default win_x64 folder.

Are you having issues compiling? (Errors)
It appears all the binaries are being produced.
Thank you for helping.
no errors, but the file "CryScaleformHelper.dll" is not produced and without it all the ui is not showing.
Do you know how I can produce it?

Re: Not getting "release" files after compiling CryEngine

#7
Hey there,

As long as you don't modify CryCommon or other interface code, then you can use the DLL that is shipped with the CRYENGINE Launcher. You cannot build the CryScaleformHelper.dll yourself without access to the Scaleform SDK.

We provide a release binary for this purpose. By default, it should reside in the following location:
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64_release
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: Not getting "release" files after compiling CryEngine

#8
Hey there,

As long as you don't modify CryCommon or other interface code, then you can use the DLL that is shipped with the CRYENGINE Launcher. You cannot build the CryScaleformHelper.dll yourself without access to the Scaleform SDK.

We provide a release binary for this purpose. By default, it should reside in the following location:
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64_release
Thanks Flare,
yes I've noticed that file in the past and I've been using it for my release build. I've tought that some problems with my release could be related to CryScaleformHelper.dll that was not been compiled, but if you say this, it could not be the cause of the problems I'm having, as I've not edited the CryCommon.
Can you help me in the other thread please as the problem seems related to the encryption?
viewtopic.php?f=40&t=12146&p=26079#p26079

Who is online

Users browsing this forum: No registered users and 3 guests