Host Player Spawn Error in Multiplayer

#1
I have recently come across a new issue I have not seen before. In a multiplayer LAN game, when the host player dies, they do not respawn at a spawn point from the other players perspective.
I have 6 spawn points spread throughout the relatively simple map.
Maze_01_Map.jpg
Maze_01_Map.jpg (767.97 KiB) Viewed 1101 times
From the hosts perspective, they respawn normally at a spawn point but are not visible to the other players. They can kill the other players but they cannot see it happening.
Maze_02_In Game.jpg
Maze_02_In Game.jpg (683.49 KiB) Viewed 1101 times
From the other players perspective, the host player seems to spawn around (maybe exactly) at the center of the map. There is no spawn point at that location. The other players can kill the host player at the center location.

I have tried several flow graph iterations ranging from the simple game start connected to spawn on the initial spawn point entity to adding logic to try and force it to go to the spawn points.
Maze_04_Flowgraph.jpg
Maze_04_Flowgraph.jpg (310.98 KiB) Viewed 1101 times
Does anyone have any ideas for how to fix this issue?

Also, I'm using 5.4 if that makes a difference.

Re: Host Player Spawn Error in Multiplayer

#4
The only instance it is mentioned is here:

<!-- Note: If need to use partial same inputs as below while in menu, must be declared above to handle first -->
<!-- below gets sent to flash navigate function -->
<action name="menu_scrollup" onPress="1" keyboard="mwheel_up" />
<action name="menu_scrolldown" onPress="1" keyboard="mwheel_down" />
<action name="menu_fcommand1" onPress="1" keyboard="f1" />
<action name="menu_fcommand2" onPress="1" keyboard="f2" />
<action name="menu_switchtab_left" onPress="1" onHold="1" holdTriggerDelay="0.3" holdRepeatDelay="0.15" keyboard="pgup" xboxpad="xi_shoulderl" ps4pad="pad_l2"/>
<action name="menu_switchtab_right" onPress="1" onHold="1" holdTriggerDelay="0.3" holdRepeatDelay="0.15" keyboard="pgdn" xboxpad="xi_shoulderr" ps4pad="pad_r2"/>

I don't think this would be it though. Whenever I have pressed F2 before, it cycles through the spawnpoints. F2 is a quick fix but I'm still not sure what is causing the problem.

Re: Host Player Spawn Error in Multiplayer

#5
I just tried reinstalling the sample sdk and even using a different version 5.5.2. on both machines that I am using to test multiplayer.

I started a new map only bringing in the layer with the maze walls and floor. Created new spawn points. I still get the same error. There are no lights, no entities, no logic, and no changes to any scripts.

The models of the maze walls can't cause this error, can they? Do I need to wipe CRYENGINE completely from my computers and clean the registry? I'm running out of ideas.

Re: Host Player Spawn Error in Multiplayer

#6
I reinstalled 5.5 and then started a new map and set the objects up from scratch. The issue could have been that I set the maze center at xyz 0,0,0 giving part of the map because coordinates? Either way that issue is fixed. Hope this helps someone later. Keep all maps in the positive xyz :)

I still have an issue with the HUD showing black boxes where the elements would be. It goes away if I go to the graphics settings and change them (to anything, any change will work).

Who is online

Users browsing this forum: No registered users and 1 guest