Schematyc Rotation Help

#1
Hey there, I've been trying to set up a FPS style controller using schematycs. I have been trying for weeks now, and have finally got it to start rotation, however, 2 issues continue.
1) The player only rotates in 1 direction (assuming mouse movement is the issue as the check always turns out false)
2) The player only rotates while moving, and after movement stops, the angle of the player reverts to the old camera angle.

I am using the schematyc blank project template for this, and i'm not much of a programmer, more of a modeler. However, for my purposes currently, just having a character that can move around in the world like this would be helpful. I have tried other c#, c++ templates as well as coding my own c#, however coming from UE, and Unity, this is quite the leap up, in coding as well as graphically. Since I'm focused more on graphical aspects right now, CE seems to be the best option for me and my friend.

Attached are pics of what I have for it. One is the update function, and the other is the main function for rotation (currently only focusing on horizontal rotation, but, will be doing vertical as well at some point, and a few other functions. Anyways, if anyone can pick out what is going wrong with this, please help me here. I am trying to understand schematycs a bit more. If you need more information, let me know. Thanks,
Attachments
2.png
Rotation
2.png (96.51 KiB) Viewed 571 times
1.png
Update
1.png (94.87 KiB) Viewed 571 times

Re: Schematyc Rotation Help

#4
Thanks, that helps a bit. Unfortunately, after rotating past the clamp (which I extended to a higher value), it cuts the entire display area out, and terrain. Any idea why? Since it's for a FPS, the clamp feature wouldn't be good for the mouse X. but, the rest I didn't even think of, thanks again. Just need to figure out why it's glitching the screen after 80 degrees of a turn.

Re: Schematyc Rotation Help

#7
Thanks for the link. but as I still get this occurring (see picture), when rotating when bypassing the clamp on x mouse movement. As much as c++ is an optimal choice, I am kind of hoping to do this if possible with just schematycs so i can learn a bit more, and try to get something simple. As mentioned, I am a modeler more than programmer. Does anyone know why the screen does this?
3.png
screen issue
3.png (604.37 KiB) Viewed 497 times

Who is online

Users browsing this forum: No registered users and 0 guests