Re: CRYENGINE 5.6 Build Feedback Thread

#32
I'm currently at 5.4, but have tested the new version:

=========================================================================================================

Title: [CharacterTool] - UI displays incorrect playback duration
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description:
  • PlaybackPanel:
    • Animations works, but max duration is always 1
    • On My, Motus and SDK animations
    • Playback duration tested with version 5.2 and 5.4 - worked fine
Image

Additional: =========================================================================================================

Title: [CharacterTool] - Memory leak in BlendSpace
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description: =========================================================================================================

Title: [Engine] - Memory leak in Load/Unload
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description:
  • Memory is permanently increased with each level load
  • On Templates, GameSDK and Empty levels
  • Tested with version 5.2 and 5.4 - worked fine
Image
-- look at this draw call :) ...another bug

=========================================================================================================

Title: [3DEngine] - Auto merged vegetation doesn't cast shadows
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description: Image

=========================================================================================================

Title: [Engine] - "Breakable Glass technology" broken
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description:
  • Dynamic and physically accurate fracturing for glass won't work since 5.4
  • Tested with:
    • objects/architecture/buildings/greenhouse/greenhouse_side.cgf
    • objects/props/misc/breakable_glass/breakable_glass.cgf
    • Glass surface type
  • See 5.5 Feedback Thread or Issues#401
Image

=========================================================================================================

Title: [Engine] - High CPU Usage
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped / Compiled (#9562d7)
  • Version Number: 5.6.2.30

Description:
  • Compared to 5.4, the CPU usage is about ~2x higher with the same setting

My Comparison:
  • Woodland, DX11, Windowed, 1100x720, Spec=4, MaxFPS=-1, VSync=1
  • GameLauncher, Default cvars and without rc or sc in background
  • CE 5.4
    • r_MultiThreaded=0 [SMT=0] CPU ~29% (BGMode ~14%) | [SMT=1] CPU ~14% (BGMode ~5%)
    • r_MultiThreaded=1 [SMT=0] CPU ~44% (BGMode ~28%) | [SMT=1] CPU ~22% (BGMode ~14%)
  • CE 5.5
    • r_MultiThreaded=0 [SMT=0] CPU ~36% (BGMode ~14%) | [SMT=1] CPU ~20% (BGMode ~8%)
    • r_MultiThreaded=1 [SMT=0] CPU ~78% (BGMode ~29%) | [SMT=1] CPU ~47% (BGMode ~15%)
  • CE 5.6
    • r_MultiThreaded=0 [SMT=0] CPU ~42% (BGMode 42%) | [SMT=1] CPU ~28% (BGMode 28%)
    • r_MultiThreaded=1 [SMT=0] CPU ~65% (BGMode 65%) | [SMT=1] CPU ~42% (BGMode 42%)
BGMode = Window mode without focus (not minimized)
Specs: AMD Balanced Power Plan, Ryzen 5 1600, B350-PLUS, AGESA 1.0.0.3ABBA

=========================================================================================================

Title: [Schematyc] - Enumerate files takes to long
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Have only one schematyc script located in /Objects/Schematyc/. But CScriptRegistry::Load() search in all directories, and this takes to long
  • Registry need a option to specific the script folder

Additional:

Code: Select all

------------------------------------------------------------------------------------
< 0.042>: <10:45:52> [Schematyc]: Loading...
< 0.000>: <10:45:52> [Schematyc]: Loading settings
< 0.000>: <10:45:52> [Warning] XML reader: Can't open file (assets/cryschematycsettings/log_settings.sc_settings)
< 0.000>: <10:45:52> [Schematyc]: Loading scripts
< 3.622>: <10:45:56> [Schematyc]: Compiling scripts
< 0.000>: <10:45:56> [Schematyc]: Loading complete
< 0.000>: <10:45:56> [Warning] Unknown command: exec
< 0.010>: <10:45:56> Initializing CryAction done, MemUsage=66420Kb
------------------------------------------------------------------------------------

=========================================================================================================

Title: [Animation] - Hidden attachments cast shadow
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Hidden attachments cast shadows, when "Hidden"-option in character file activated
Image

=========================================================================================================

Title: [AssetSystem] - Asset browser empty, CryAsset required
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Files without an metadata (cryasset) file are not listed
  • CVar ed_enableAssetPickers won't work anymore
  • Menu generate/repair does not work (editor and rc log say nothing)
Image

Sure it's a nice to have feature, but it should not be required for all files. For what? Only for the Dependency Graph Plugin?

=========================================================================================================

Title: [MaterialEditor] - Missing features
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

The current material editor is a big step back, compared to the legacy one.

Description:
  • Tooltip won't work without an extra preview thumbnail file (ed_generateThumbnails=0)
  • Requires external programs to view alpha channel, original size
  • Current Editor need the BitmapToolTip feature from legacy version
  • Material should highlight once, when selecting. like the legacy version
  • Option "Assign to selection" missing in menu and context menu
  • All texture map will renamed to .dds, so i cannot assign an .ui file
Image

=========================================================================================================

Title: [GameSDK] - Skybox material broken
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • All Materials/sky/*.mtl files are broken
  • sky.mtl from EngineAssets folder works
Image

=========================================================================================================

Title: [GameSDK] - Lightbeam material broken
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Lightbeam materials (lights\light_beams\*.mtl) use the none exist Shader "Lightbeam.LightBeam"
  • Only TemplBeamProc Shader exist for light beam effects
=========================================================================================================

Title: [RC] - Cannot compile 8K textures
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Tested with version 5.2, 5.4 and 5.5 - worked fine

Additional:

Code: Select all

------------------------------------------------------------------------------------
0:00 Memory: working set 8.9Mb (peak 8.9Mb), pagefile 4.2Mb (peak 4.2Mb)
0:00 Spawning 1 thread
0:00
1> 0:00 ---------------------------------
1> 0:00 File='hair_chunks__default_lod0_diff.tif'
1> 1:45 Processed DDS (89478480 bytes): hair_chunks__default_lod0_diff.dds
1 file processed in 105.0 sec.
[E]: Memory: working set 10.7Mb (peak 5728.6Mb - DANGER!), pagefile 6.2Mb (peak 5734.9Mb)
Finished at: Mon Oct 14 12:48:35 2019

1 errors, 0 warnings.
------------------------------------------------------------------------------------

=========================================================================================================

Title: [Shader] - Hair shader params won't work
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
    • Material Editor:
    • Lighting settings has no effect
    • Shader params has no effect, except Alpha blend multiplier
  • Hair shader tested with version 5.4 - worked fine
=========================================================================================================

Title: [Sandbox] - Hamburger menu
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30
Sandbox need an option to bring back the display menu. Working with the Hamburger menu is so painful and slow down the workflow

=========================================================================================================

-- Hope some bugs will fixed in this minor version. CE should stop implementing new feature, and begin with testing and stabilization

Love CryENGINE, but each version has new bugs
~Germany

Re: CRYENGINE 5.6 Build Feedback Thread

#33
Title: [System, Logger] - Incorrect log location
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Game*.log and Editor*.log are written into engine folder
  • But they are project specific. project specific files > in project folder
  • Command line: e.g. "-logfile %~dp0client.log", has no effect
=========================================================================================================

Title: [GameSDK] - Shader compile error at Watervolume
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Compile error, when using material: water/watervolumes/water_algae_surface.mtl on DX11

Additional:

Code: Select all

------------------------------------------------------------------------------------
Compile Watervolume@WaterPS(GL89)(RT1000000002000001)(PS) (0 instructions, 0 tempregs, 0/0 constants) ...
Watervolume@WaterPS(X1)(89)(167,10-24): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(948,50-75): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(970,3-33): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(974,3-33): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(979,3-57): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(1023,3-54): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(1059,15-64): warning X3206: implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(1060,14-57): warning X3206: 'lerp': implicit truncation of vector type
Watervolume@WaterPS(X1)(89)(58,14-32): error X4500: overlapping register semantics not yet implemented 's0'
[Warning] Couldn't compile HW shader 'Watervolume@WaterPS(X1)(89)'
------------------------------------------------------------------------------------
=========================================================================================================

Title: [FacialEditor] - Sandbox plugin broken
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Preview panel, does not work
  • Load character, does not work
  • Load audio sequence, does not work
  • ...Nothing works
=========================================================================================================

Title: [Engine] - Cubemap preview not displayed
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Cubemap preview in sandbox is not displayed (option preview = checked)
  • Both: Misc > Environment Probe and Components > Light > Environment Probe*
* Environment component only when selected

=========================================================================================================

Title: [Sandbox] - Menu "Goto Position, Selection" is not working
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Entry "Go to Selection" and "Go to Position" in the toolbar does not work
  • Menus "Sandbox > Level > Go to ..." too
=========================================================================================================

Title: [Sandbox] - Rotation, Scale warn icon missing
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • Option activated in: Preferences > Viewport > Debug
  • Sandbox shows only squares with "Replace Me" texture
=========================================================================================================

Title: [Engine] - Camera "Safe Frame" broken
  • OS: Windows 10 (build 10.0.17763)
  • Build: Shipped
  • Version Number: 5.6.2.30

Description:
  • The "Safe Frame" is not displayed
  • Only visible in Wireframe -Mode ...in the Terrain ...lol
Image
~Germany

Re: CRYENGINE 5.6 Build Feedback Thread

#34
What does the e_StatObjBufferRenderTasks cvar? This increases the performance significant and is enabled by default! When disabled, i have a 50% performance gain.
The impact on previous versions was much lower.

Can anyone confirm that?


Specs: Windows 10, Ryzen 1600, GeForce v430.86 SD, B350-Plus, AGESA 1.0.0.3ABBA, 5220
~Germany

Who is online

Users browsing this forum: No registered users and 2 guests