Doubts for Third Party SDK for CryEngine 5.5.2

#1
This topic is based on: https://docs.cryengine.com/pages/viewpa ... d=29800269 that gave me a lot of questions and work to make this post.
Back on my first installation (5.3) I tried to get it direct code on the github by cloning the download, this time I was unable to create the build so I installed the Cryengine_Launcher. I think I’ll install Git and Tortoise latter. I still messing around whit the engine but I’ll target CryEngine for PC Games later on.
I don’t think swig, nunit and Mono suits my needs, my focus is on CPP. And I’ll not develop for VR now. And I can’t not afford Substance so I’ll skip Substance Engines and any type of software with subscription model business. Instead, I will make use for open source tools like Blender, Gimp, Audacity, and BandLab Cakewalk as a DAW.
I just download the third party as sources, lib or sdk. So please, say one of the package need to be a binary version and the local to be placed.
I just want to talk that I’m obsessed with Vulkan. I have a more recent Sdk for vulkan, but I did another installation for the needs of the CryEngine 5.5.2, the version 1.1.70.1 was installed directly Crytek\CRYENGINE_5.5\Code\SDKs. The folder was named “VulkanSDK”.
I think this problem is solved using git by command line with the recursive parameter to download all of the dependencies, but here I want to try doing with the launcher to later (maybe) I can customize, so here I go:
The SDL with Vulkan support! I see the last version 2.0.9 has the support, not the 2.05. I don’t think this is an issue.
Does the Sandbox editor still need the Perforce API? I think it's the Helix Core C / C ++ API for Sandbox for C/CPP projects. But the versions available are 2017.2 up until 2018.2 as older version and 2019.1 is the last. No way to get the 2015.1 release. But if I can create a new feature in the engine (did on the project folder, maybe?) and create an respectively editor in Sandbox for that function, can I forget this issue because the actual Sandbox is using QT?
I just can’t find XT_13_4 lib/api/sdk at all. What this lib do and why I would need.
Portaudio v19_20140130, Speex, flac, libmikmod, libmodplug, libogg, libsndfile, libvorbis will be in the location: Code\SDKs\Audio?
Jsmn Parcer is in 1.0.0. This is ok? And the location too.
I was unable to find the version of the squish-ccr for texture compression, hosted in github, no release state.
BigDigits is in only in the 2.6.1 version. I don’t have permission to take an older folder.
I suppose the alemic lib is from www.alembic.io? There are other libs called alemic. I downloaded the alembic.io from github
I found an implementation of lzss on https://github.com/MichaelDipperstein/lzss. No release but is something.
The LZMA SDK can be found on the 7zip site in the versions 19.00, 18.01 and 16.04. I download the 19.
I was not able to find the sdk for MD5
I found libstrophe at https://github.com/strophe/libstrophe. Any versions do?
I found QT at https://download.qt.io/archive/qt/5.6/5.6.3 the probably source code is in “single” subfolder. I download the file qt-everywhere-opensource-src-5.6.3.
Brofiler as ben renamed as Optik and the version says custom. Well, I took the 1.2.2
Not able to find the “Tangent Basis Computation” file.
CrashRpt/1403 is a dll?
Sdl_Vulkan is just an .h file? Well I just put a folder SDL2_VULKAN and the file inside.
spirv-cross has versions named date like 2019-04-26, so I’m not sure.
I find astc-encoder at https://github.com/ARM-software/astc-encoder. And the versions shows 1.4 and 1.3.
There are 2 Netgen software, one is https://ngsolve.org and other is https://sourceforge.net/projects/netgen ... en-mesher/. And no one as the 4.3.1 version. Netgen-mesher has the 4.9.5 dated as 2009-01-19.
I found LibTiff v4.0.4. Just named the folder as tiff.
I took the requested version for LibTomMath, LibTomCrypt, curl, expat, freetype, hdf5, ilmbase, jpeg, lz4, ncurses, png16 and zlib. But they are not in the Crytek\CRYENGINE_5.5\Code\SDKs.
This is my current sdk tools in Code\SDKs location are: VulkanSDK, Steamworks, SDL2 (native 2.0.3), PhysX (3.4.2), NVAPI (R410), Lua (native), FbxSdk, Brofiler (native, and well, looks like the Optik is not need anymore?).
This is my current sdk tools in Code\SDKs\AMD location: AGS Lib Extra, AMD_Extensions.
And the Code\SDKs\Audio location: SDL_mixer, wwise and fmod (this can be considerate a mistake that I took since in my first install, but I think that I’ll favore the Wwise, and yes I took the version need for 5.5.2).

Who is online

Users browsing this forum: No registered users and 0 guests