lighting is strange

#1
Hi guys,

I am new to CryEngine, here I met a strange problem when pakaging my project, you can see the image below:
image 1 is what is like in sanbox editor:
image 1.jpg
image 1.jpg (815.64 KiB) Viewed 204 times
image 2 is secne running in GameSDK.exe, you can see the light is strange for some object:
image 2.jpg
image 2.jpg (757.47 KiB) Viewed 204 times
I have checked all resource that is needed for my level, such as textures and materials.etc. And still can not figure out this problem.
Can someone help me about this, thanks a lot!!

Re: lighting is strange

#2
Hi guys,

I am new to CryEngine, here I met a strange problem when pakaging my project, you can see the image below:
image 1 is what is like in sanbox editor:
image 1.jpg
image 2 is secne running in GameSDK.exe, you can see the light is strange for some object:
image 2.jpg
I have checked all resource that is needed for my level, such as textures and materials.etc. And still can not figure out this problem.
Can someone help me about this, thanks a lot!!
looks like a specular/glossiness problem, did u try to take a look at that parameters? also be sure to have exported to engine your level before packaging everything
Image

Re: lighting is strange

#4
yes, when I add detail mapping in the material, it show correctly, but not all materials have a detail map, may be some shaders are missed or not compatible?
from what i know every models should be available to get detail map, i never used it but i read the documentation about it and your texture should exported as Detail_MergedAlbedoNormalsSmoothness out of photoshop you did it correctly?
Image

Re: lighting is strange

#5
yes, when I add detail mapping in the material, it show correctly, but not all materials have a detail map, may be some shaders are missed or not compatible?
Yes, not all them. From what I can see these are stock assets, am I correct? If so I'd presume they are quite old by now. They use DDS by default so perhaps there this is some compatibility issue indeed. Does the problem persists with your own assets?
GorbashGaming - Beginner Tutorials for CE https://www.youtube.com/channel/UCIjN10 ... Img/videos

Re: lighting is strange

#7
yes, when I add detail mapping in the material, it show correctly, but not all materials have a detail map, may be some shaders are missed or not compatible?
from what i know every models should be available to get detail map, i never used it but i read the documentation about it and your texture should exported as Detail_MergedAlbedoNormalsSmoothness out of photoshop you did it correctly?
I have three textures for one model: albedo, normal and specular glossy, but no detail map. So which one should I export as Detail_MergedAlbedoNormalsSmoothness?

Re: lighting is strange

#8
yes, when I add detail mapping in the material, it show correctly, but not all materials have a detail map, may be some shaders are missed or not compatible?
from what i know every models should be available to get detail map, i never used it but i read the documentation about it and your texture should exported as Detail_MergedAlbedoNormalsSmoothness out of photoshop you did it correctly?
I have three textures for one model: albedo, normal and specular glossy, but no detail map. So which one should I export as Detail_MergedAlbedoNormalsSmoothness?
yes that's the right format http://docs.cryengine.com/pages/viewpag ... d=25534115
Image

Who is online

Users browsing this forum: No registered users and 3 guests