Engine not starting?

Hello everyone, i have some problems with engine start, it wont launch. Maybe i do something wrong?
In log it says
<14:24:52> Direct3D driver is creating...
<14:24:52> Crytek Direct3D driver version 3.00 (Dec 6 2019 <12:50:43>)
<14:24:52> Creating window called 'My Project' (32x32)
<14:24:53> [Error] DeviceInfo::CreateDevice() failed
<14:24:53> [Error] Rendering device creation failed!
But crаshes. Why 32x32? Why crаsh? Maybe it went wrong because of dependencies, at panels with "sdk" and "tools and plugins" at many items it says "install", not "installed". Even if it really installed, of course. I tries 5.0 version of engine, it not crаshes, but launch takes eternity.
I have 8 core amd cpu, 4gb 1050 and 10gb ram, it enough for many purposes, i think, it must be enough even for cryengine.
In this thread viewtopic.php?f=9&t=11047&p=24755&hilit ... led#p24755 i found another CryRenderD3D11.dll from 5.5 engine. But it cant get any worse. With this dll in logs are another errors.
<14:43:45> - Feature level: D3D 11_0 (SM 5.0)
<14:43:45> - Displays connected: yes
<14:43:45> - Suitable rendering device: yes
<14:43:45> Loading Module CryRenderD3D11.dll...
<14:43:46> Failed to get module info for 0x373dbe8, last error: 126
<14:43:46> Failed to get module info for 0x30d838, last error: 126
<14:43:46> Failed to get module info for 0x50, last error: 126
<14:43:46> Failed to get module info for 0x30d440, last error: 126
I don't found any solution and another ways to solve this problem.
Sorry for language, it far from good.

Re: Engine not starting?

is this a project based on a template which was started before 5.6.5 ?
If it is based on a template, we would recommend you take the similar project file (cryproject) from the new version and put this into your project.
If your project already has significant modifications, it would be best to right click on the project file and select "Generate Solution".

Re: Engine not starting?

I tried old dll because engine is not launches. After that i clicked "validate installation", launcher download something about 300mb. And project again not launched.
I tried deleting engine and reinstall. And tried to separate download 5.0 version with separate project. No results.
How i can validate dependencies? Tab "Ide and compiler" has green check mark, but "Sdk and dependencies" has not any marks. I already installed fbx sdk, but launcher prompts "Install". Same with "CryToolsInstaller".

Re: Engine not starting?

If you are using the engine provided by the CRYENGINE Launcher, you need not worry about SDKs in the dependencies. These are for compiling the engine yourself from source code.
Once you have downloaded and installed CRYENGINE 5.6.5, please create a new project and let us know if this new project launches correctly.

When migrating projects from older versions of the engine, it is best to create a new project using the same template, then copying your assets into the new project from the old one. This way you still have your old project in case of issues.
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 1 guest