cry_waf.exe says: No msvc compilter installed on this machine


i installed visual studio 2017, added c++ by clicking: game development with c++ (free translation from my german user interface)
but cry_waf complains, ive looked at:


and it looks for:

Code: Select all

call :CheckCompiler %1 "HKEY_CLASSES_ROOT\VisualStudio.DTE.14.0" "Visual Studio 14 2015 Win64" call :CheckCompiler %1 "HKEY_CLASSES_ROOT\VisualStudio.DTE.15.0" "Visual Studio 15 2017 Win64"
which looks ok to me, but i dont have any knowledge about windows scripting, just linux.

im currently running a windows 7 / 10 dual setup, 7 being the system im currentlly trying the cryengine stuff on and its installed on e:\, is this maybe a problem?
all ms related stuff is also o e:.

i can run: E:\Users\julius\Desktop\CRYENGINE-release\Tools\CMake\cmake_create_win64_solution.bat manually and it seems to generate just fine, says:

Code: Select all

Configuring done Generating done
shouldnt that be enough for waf_cry to work?

Re: cry_waf.exe says: No msvc compilter installed on this machine

thanks for the fast reply, in the meantime i tried all this on windows 10.

when following the beta instructions they seem to skip a step where you tell cryenginexyz where its codebase is, creating a solution gives me:

Code: Select all

The code folder has not been specified in the project file!
which is kinda awkward because it downloaded about 800mb which kinda sounded like the engine?
so i created a new project, same error. this time preview 5.5 was already installed and it did not download the files again.

i have this crazy idea about running: ./configure --preifx=/home/myuser/cryengine && make && make install.
if someone could just invent this....would be awesome, but hey, lets make it a bit more complicated ;)

Who is online

Users browsing this forum: No registered users and 0 guests