Loading Localisation Soundbanks

#1
Hi,

I'm using 5.5 preview 4 with Wwise. I have a soundbank for voices which is currently only in one language - English (US). When I build the soundbanks in Wwise this soundbank is placed in a separate folder (as you can see in the screenshot of the folder structure) as expected. The only problem is this folder isn't appearing in the ACE (shown in the other screenshot). I'm sure it used to appear in older versions of the engine, but now it's not visible. How do I go about setting this up?
Attachments
Folder Structure.png
Folder Structure.png (42.13 KiB) Viewed 601 times
ACE.png
ACE.png (13.61 KiB) Viewed 601 times

Re: Loading Localisation Soundbanks

#2
Hi tomavis,

That's expected behavior as the engine expects to find localized data under <projectroot>/localization/<language>/audio/<middleware>/assets
In your case <middleware> is wwise
<language> is the string set via the g_languageAudio cvar

We do provide scripts that can be run as a "Post-Generation Step" in Wwise. You'll find those in the GameSDK Wwise project under CrytekScripts. Find it as a free download at the marketplace here. https://www.cryengine.com/marketplace/c ... se-project
temp2.png
temp2.png (17.16 KiB) Viewed 596 times

Re: Loading Localisation Soundbanks

#4
It just makes sure that the ACE displays localized soundbanks properly which are as well equipped with a dedicated icon. See screenshot below. Those banks can then be handled like any other bank. The only difference is that those get swapped out whenever the language cvar changes.
temp3.png
temp3.png (14.8 KiB) Viewed 566 times

Who is online

Users browsing this forum: No registered users and 5 guests