Material editor does not show textures

I've just started to use CEV and I've immediately hit a serious problem with the material editor.
I'm using GameSDK. I was able to load several aircraft models from my 5.3 simulator, which is good.
But I've found that I can't change the texture assignments in the material editor.
Model path: GameSDK/Objects/Aircraft/F-16/Models/main.cgf
The path is obviously fine, as I can load the model.
If I open the material editor for the model, everything looks fine, see screen shot.
But if I click the Diffuse button to browse for another texture, there's a big problem: as shown in the screen shot,
it doesn't open at the location for the existing texture as it should. Worse, the browser does not show the Aircraft
directory at all.
It looks as if the texture browser is only showing items in the .pak files, which is completely wrong.
Does anyone have any ideas?
Many thanks,
Sandbox5_52.jpg (244.44 KiB) Viewed 3257 times

Re: Material editor does not show textures

Hi lavizh,
Thanks for the help. Looks like your suggestion about the cry assets was spot-on.
I right-clicked the cryproject file and generated the files. All the .cgf files then had cryasset files - but only two of the dds files.
Now, when browsing for texture files in the material editor, it shows the objects/aircraft folders which contain my cgf files. But it still doesn't show the
texturers folder which contains the dds files - maybe because most of the dds files did not get asset files. So it's still unusable, some of my models
show incorrect textures, so I need to use the material editor to investigate/correct.

I would like to completely disable this asset thing. My simulator has very many files, and I certainly don't want it to be bloated by these probably
useless files. So, will the CVAR disable the asset system, which would stop the creation of these files and also hopefully fix the material editor problem?
I searched for asset in the CVAR list but didn't find anything obvious (there were three that included "asset").
I would be very grateful if you could let me know which CVAR I should use. Basically, I want the asset thing to go away completely!

I'm trying to like CEV, but it's a struggle. At the moment I think the old Sandbox is far better: it does everything I need and it's intuitive and easy to use. It's a relief to get back to CE3!
But I'll stick with it, maybe it'll grow on me.

I have found one thing that I love: it can run in true full screen (CTRL-space but, strangely, the command activates only in editor mode, although full screen would normally only be used in
game mode). This is great for my simulator because, in pretty well all CE versions I've used (starting with CE1, the Launcher never worked properly for my simulator. It's best run in Sandbox.
The other thing I do like is the snow on ground feature. Now that my simulator covers the entire world it would be great to see the snow on the terrain increasing as I fly north!
Many thanks,

Re: Material editor does not show textures

Hi lavizh,
You may have missed it, but I'm still stuck, I would appreciate some help.
It looks like the asset system is causing the material editor problem. You said there was a CVAR that might do the job.
Could you let me know which CVAR to use (I've searched but didn't find anything). Also, information on the asset system or a link to the docs would be very useful (I searched the docs but didn't find anything).
Many thanks,

Re: Material editor does not show textures

Hi lavizh,
Looks like I spoke too soon!
As far as I can tell, setting the CVAR to zero does fix the material editor problem.
But now there's a similar problem with the asset browser.

I copied some folders that contain .cgf files into Objects.
But there was no sign of them in the asset browser. It correctly shows previous objects (but they do have associated cryasset files).
As a test I copied a known good .cgf directly into Objects. It did not show up in the asset browser. It started to look as if it was only showing .cgf files that have associated cryasset files.
The CVAR is set to zero in editor.cfg. It was always zero when I checked in the console.

So, as a final test, I deleted the cryasset files for a folder that previously showed up correctly. Result: now the folder does not show up (after reloading Sandbox).
So, it looks as if the asset browser is only showing .cgf files that have associated cryasset files, although the CVAR is definitely zero.

Am I right in thinking that, with the CVAR zero:
1. cryasset files will not be created.
2. cryasset files are not required for correct operation.
If so, then maybe it's a bug.
Hopefully there will be a solution for this. By the way, is the asset browser the only way to load objects into the map?
Many thanks for the support.

Re: Material editor does not show textures

The asset browser does indeed need .cryasset files to function properly. By disabling Asset Pickers you disable the way you select assets. This does not disable the cryasset functionality.
You can test this by trying to assign a texture to a material. Then doing the same after you disable the Asset Pickers. Notice how the dialog changes.

When you import assets, you need to go to the Asset Browser, then under the edit menu choose "Generate/Repair all metadata".
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: Material editor does not show textures

Hi Cry-Flare,
Many thanks for the help.
I did a "Generate/Repair all metadata".
It took well over five minutes.
The .cgf files that previously had an asset file now have an additional .png thumbnail - so each .cgf has three files! I really hate this.
But many cgf files still have no asset files at all, so I can't see them in the asset browser. Even a .cgf directly placed in GameSDK/Objects dos not have an asset file.
So, there seems to be a problem with "Generate/Repair all metadata"

I am constantly exporting new model versions into Sandbox, would I have to do "Generate/Repair all metadata" every time? That would drive me mad!

Some questions:
1. Can the entire asset system be completely disabled (e.g. so it works the same as CE3)?
2. Is there an alternative method for loading objects that does not use the asset browser?

Currently CE5.4 is completely unusable for me. I hope there is a solution, otherwise I will have to abandon CE5.
My simulator works very well on CE3, I hope eventually it will work as well on CE5 - but I'm not very optimistic.
Many thanks,

Who is online

Users browsing this forum: No registered users and 0 guests