Re: LUA Support In Upcoming Versions

First you need to unpack the Scripts.pak file.
Inside you will find the entities.xml.
This is the list of entities. It is pretty self explaining.
It is the same xml structure that you had inside the .ent file (a name and the path to the LUA script). Only difference is, that all entities are defined inside the entities.xml and dont have a custom .ent file anymore.
Just add your entites at the bottom.
If you have any problems, let me know. I'll give you a more detailed description if you're still having trouble.

- Jannis

Re: LUA Support In Upcoming Versions

Hi Jannis,
Apologies for not replying sooner but I've had an almost complete Internet breakdown, but at last they've fixed the problem today.

Many thanks for the help. But - this is embarrassing! - I can't find the .pak file.
There is a scripts.pak in
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.3\gamezero
but it contains just one Lua file.

I've installed one addon - Trainyard - but it doesn't show up when I run Sandbox.
I'm guessing I need to install the main assets addon . Now that my Internet's working again I'll download it, hopefully it does contain the file.
Many thanks,

Re: LUA Support In Upcoming Versions

Hi, at first I thought that the Lua support would be removed, but there is a component interface for Lua script. I think in the end it will look like the lumberyard they will remove the dependencies of the entities but it will be possible to use as a component of the entity. It would be strange to create this component if they had no interest in continuing to use the language.

The interface isIEntityScriptComponent in IEntityComponent.h.

Re: LUA Support In Upcoming Versions

Hi Jannis,
I don't remember actually choosing Game zero, it just happened! I think CEV is very confusing.
I think Crytek should offer CEV optionally as a zip like the free SDK. Then at least you know where to find the files.
Currently my CEV is distributed on two drives.
I can't even find the free assets download. When I visit the market place I can only find the paid for assets, not the free ones.
I did download the trainyard addon but it doesn't show in Sandbox.

There's no sign of the entities.xml in the Assets directory (I installed my objects there and they work).
I wonder if you could do something for me: post a sample entities.xml and give the path where it should be placed.
Hopefully that would at least enable me to load my entities.
Many thanks for the help,

I originally installed 5.0 and after a *lot* of work got my vehicles working. But I found a serious problem with my autogen system, which places large numbers of scenery objects in entity slots.
It looked like either a bug, or that Crytek had massively reduced the number of objects in slots. Of course, this works beautifully in CE3. Unfortunately Crytek do tend to introduce limits
that are pointless and only serve to reduce the power of the game engine. To be honest, I'm not optimistic about Cry Engine's future.

My plan was to install 5.3 when it was released and test to see if that problem had been fixed. If still a problem and no help from Crytek then I would probably abandon CEV. Of course, dropping Lua is another big negative for CEV.
Anyway, with a bit of help hopefully I can get my entities working, and then I'll check that problem.
Once again, many thanks!

Re: LUA Support In Upcoming Versions

Hi chris. I'll post an entities.xml file e.t.c. as soon as I'm home. I hope that you can get it working. But CryEngine 5 is really not that bad. It just needs time to dig into it. But I agree, that the decision to drop LUA is a reallly bad idea. Furthermore, the templates are pretty useless. I'm still using the GameSDK project.

Anyways, if you have any questions regarding the engine and structure, you can ask me at any time.

- Jannis

Re: LUA Support In Upcoming Versions

All right. I just copied the entities.xml for the GameZero project and the one for the GameSDK project into a .rar.
The "entities.xml" has to be placed into your Assets file. Don't place it in a subdirectory (so don't move it into the script folder or any other folder).
This should work. If it doesn't work, then it would bee good if you can make some screenshots of the folder hierarchy inside your project.

Regarding the marketplace: You can find the CryTek stuff here (4 pages): ... 795776?p=1

You'll also find the GameSDK project e.t.c. there. However it seems as if the marketplace does not work properly currently. I just tried to add the c++ entity sample to the card but I can't check out. I'm just getting an empty red box at the top without a message...
Anyways. As soon as they fix the problem, you can add the asset packs to your card and check out. The asset packs are then available in your launcher under "Library -> My Assets".
To use them, you can simply click on the arrow next to "installed" (of course you need to download them before that) and choose "reveal in explorer". Now you can copy the assets over into your projects "Asset" folder. Then the editor and engine should automatically recognize them.

- Jannis
(2.05 KiB) Downloaded 177 times

Re: LUA Support In Upcoming Versions

Hi Jannis,
Thanks very much for the help. I really appreciate it.
With your link I found the free assets and the SDK assets I was looking for. But, like you, I found the market place failed miserably.
Each time, after entering my details and clicking on SAVE it just re-opened the same requestor. I'm sure my details were correctly entered.
So maybe the market place is currently broken.

Thanks for the entities.xml, that allowed me to set it up. But no joy. (note, you can skip to the update!)
The screenshot shows the setup. Create Object doesn't show the entries defined by entities.xml, for example I would expect to see an entry named "Aircraft", as that's defined in entities.xml.
More worrying, it also doesn't show my brushes if I select Brushes. It definitely showed my brushes a few weeks ago, I think I was able to load the brushes.

Oooops, now I can't even show the screenshot, it says the file is too large. Completely ridiculous, the file is just 300 kb.
OK, I cut out part of the image and it's accepted it now, size is 245 kb.

You can see the trainyard pak in Assets. That also doesn't show up. I'm wondering if the game engine is not using this Assets location.

********************* Update ********************
As I was looking at the layout I had an idea, and it worked. I installed CE to drive D:\ and that's where Assets was located, so that's where I placed the files.
But Sandbox is actually run from drive C:\
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.3\bin
I noticed that the pak files (which contain very little) are located in
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.3\gamezero
So, I copied my files into gamezero, and it works!
I loaded the two aircraft entities. I also copied the trainyard pak there and that also works.
So, there is no Assets folder involved, the files including entities.xml go directly in the gamezero folder.
Thanks *very* much for the help, no I can probably install enough of the simulator in order to do the crucial test (to check that CE 5.3 can handle large numbers of objects placed in slots, the same as CE3).
If the problem persists I'll try to get help from Crytek. If there's no fix and it's caused by an intentional limit, then I'll abandon CE5.

At the moment I have a very negative feeling about CE5. Everything seems more complex, less intuitive and clunky. For example, loading objects is now a pain, as I have to explicitly select entity or brush from the Create Object dropdown selector. Previously you just had to click one of the rollup buttons to selecvt brush, entity etc. In my opinion the old rollup system was far superior to the new regime.
One question about the interface: the old Sandbox had a line of essential selectors right at the bottom of the screen (e.g. set move speed, show and set object positions, GoTo). Can this be enabled in the new interface? I hpe so, as I regard this as essential.

Also, if there will be no means of using Lua in future versions (including the script binds), then all this may be academic. For me, no Lua means no CE5. I would do all further development on CE3. CE3 is still a very powerful game engine as well as being much easier to use.

Well, thank you very much for the help. Now i should be able to make some progress with CE5!
Best regards,

Note to forum administrators:
As noted above, I was initially unable to upload a screen shot because it was too large at just 300 kb. After reducing it to 245 kb, it worked, at least in the preview.
This was never a problem in the past, it looks like the limit has been set much too low.
So, please, reset the max file size to at least the value it used to be.
Also, as mentioned above, the market place seems to be broken.
Many thanks.
Image2.jpg (244.11 KiB) Viewed 5359 times

Who is online

Users browsing this forum: No registered users and 1 guest