Page 2 of 7

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Fri Mar 23, 2018 8:20 pm
by dennis
Title: Physical breakable glass shader/surface does not show any crackes when hit, surface just disappears
  • OS: Windows 7 64 bit
    Build: Original builds by Crytek
    Version Number: 5.4 and 5.5 Preview 1
- The glass surface just vanishes after the first hit without any indication if the glass surface was destroyed or just cracked.
- Can be tested by using original object from GameSDK/ objects/architecture/buildings/greenhouse/greenhouse.cgf and shooting at the glass planes
- Breakable glass tested with versions 5.2 and 5.3 - worked fine.

Additional notes:
Also created an issue on github: https://github.com/CRYTEK/CRYENGINE/issues/401

Error appears when loading in object with breakable glass surface in preview build 5.5:

Code: Select all

[Assert] Condition: !pTexture || !m_renderTargets[0].pTexture || ( pTexture->GetWidth() == m_renderTargets[0].pTexture->GetWidth() && pTexture->GetHeight() == m_renderTargets[0].pTexture->GetHeight()) [line 140] [File=D:/jk/workspace/gamesdk_release/Code/CryEngine/RenderDll/XRenderD3D9/DeviceManager/DeviceRenderPass.cpp] [Assert] Depth target is smaller than the color target(s)! (Condition: (!pDepthTarget || !pColorTarget0 || pDepthTarget ->GetWidth() >= pColorTarget0->GetWidth()))[line 62] [File=D:/jk/workspace/gamesdk_release/Code/CryEngine/RenderDll/XRenderD3D9/GraphicsPipeline/Common/SceneRenderPass.cpp]

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Mon Mar 26, 2018 7:54 am
by fury22uk
Problem : Networking with Animation component
System : Windows 10
Build : 5.5 Preview 1 from Launcher

Description:

So apart from being unable to use mysql connector with 5.5(as I posted in previous post in this topic), Networking in 5.5 doesn't work at all when applying some components.
For something like rolling ball it works, it has only input component and camera(camera is client only anyway).
When I attach CAdvancedAnimationsComponent (from default components) in C++ (of course I follow rule to physicalize before binding to network), Then with animations component attached, right after I connect to the server, it disconnects WITHOUT ERROR! And I tested it on pure project template, so I made sure none of my own code would interfere. Nothing crashes, server still works, only client gets disconnected. It connects succesfuly, but as I said, without any error, it disconnects just like I would have typed disconnect cvar.

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Mon Mar 26, 2018 5:40 pm
by graf_fridula
Problem : Material editor - non editable properties.
System : Windows 10
Build : 5.5 Preview 1 from Launcher

I can´t edit the properties of a material I created some time before. I don´t know what might have triggered this bug.
When I create a new material everythings fine with that one.

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Sun Apr 01, 2018 4:32 pm
by enes77
a complete list of bugs on windows 10 preview build:

-modifying road width properties causing disappearing of road on terrain (this happened in 0.25meters terrain)

-can't select decal properties (material to browse and change to another material)

-when starting engine, multiple windows of sandbox are opening for no reason (like 20-40 windows)

-none of the AA modes are working nor sharpening filter

-probes are broken when generated, causing flickering and lighting is disappearing

-enabling gi mode 1 causing engine crash

-material Editor doesn't really update the textures when applied like before

-opening some windows are quite slow and sometimes icons are disappearing

-sun specular just shining through the whole terrain

-terrain shadows are not displayed in correct way / half shadowed-half "not-shadowed"

-automerged objects do not cast any shadows

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Sun Apr 01, 2018 11:46 pm
by FerdinandDeMedicis
I'm having a small but annoying issue in 5.5. When opening a scene, the specular maps aren't visible on my models. Opening the material editor and picking any material from the scene fixes that though, but you might want to fix this bug.

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Tue Apr 03, 2018 6:59 pm
by igor_shepard
Where the hell is LOD generator and promised terrain weighted painting???

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Tue Apr 03, 2018 8:27 pm
by Mind-Revolution
Yeah, how W.Blend for terrain mats works someone please.. :|

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Tue Apr 03, 2018 9:04 pm
by noise
Where the hell is LOD generator and promised terrain weighted painting???
For weighted blending, no additional settings are needed. Just in the paint mode, uncheck the (Mask by Altitude and Slope). Vary the hardness, see how the materials will be mixed. Well, the material should have Heightmap, this texture seems to be blending materials.
Actually it looks pretty good

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Tue Apr 03, 2018 10:39 pm
by Mind-Revolution
Where the hell is LOD generator and promised terrain weighted painting???
For weighted blending, no additional settings are needed. Just in the paint mode, uncheck the (Mask by Altitude and Slope). Vary the hardness, see how the materials will be mixed. Well, the material should have Heightmap, this texture seems to be blending materials.
Actually it looks pretty good
Are you sure? because this tipe of blending cryengine have for ages.. 3.5 as minimum i believe... because i was thinking they are talking about this Weight maps ( splat maps from WM) ??

Image

Re: CRYENGINE 5.5 PREVIEW Collective Build Feedback Thread

Posted: Wed Apr 04, 2018 7:00 am
by noise
Where the hell is LOD generator and promised terrain weighted painting???
For weighted blending, no additional settings are needed. Just in the paint mode, uncheck the (Mask by Altitude and Slope). Vary the hardness, see how the materials will be mixed. Well, the material should have Heightmap, this texture seems to be blending materials.
Actually it looks pretty good
Are you sure? because this tipe of blending cryengine have for ages.. 3.5 as minimum i believe... because i was thinking they are talking about this Weight maps ( splat maps from WM) ??

Image
No weight blending really looks different, if you put hardness to a minimum you'll see the result is almost the same as the video. Previously, the materials just lay on each other, now it looks like Vertex Blending

But splat maps, I also really want, in Lumberyard it was added a very long time ago