Re: [5.3.2] Environment probe/problem

#3
confirmed ! me too has Env probe generation problem.

i created a new map under gamezero project, draw some boxes , put an env probe into the scene, and hit 'generate', then it failed to load cubemap and give me a warning:

"Compile texture from "gamezero\textures\cubemaps\newtest\environmentprobe2_cm.tif", to "d:\appcache\windowstemp\saved games\gamezero\texturecompiler\gamezero\textures\cubemaps\newtest/environmentprobe2_cm/environmentprobe2_cm.dds"
[Warning] Schedule 'Cubemap Texgen Schedule' failed on item 'Cubemap Texgen ScheduleItem'."

then i tried to load the file from game folder by hand, the cubemap actually has been generated,then i loaded it up and it worked! but don't know why it didn't load by engine automatically.
and the gizmo of env probe didn't show-up in viewport whatever how big or small when i set the Boxsize! instead, it did response to transform/scale settings.


Edit: oops....i found out that we have different problem when i carefully read through what you've posted....sorry for that..

Re: [5.3.2] Environment probe/problem

#4
cry-kane wrote:Do you have a video or screenshot of the problem?

It may be a known issue or it could be you've made a slight hickup - we will only know with some of the above.


here screen :)

Actually you need to bake probes 2 times ,1 for shadows and second time for reflections, at least older versions works like this.. but now it does not work, yeah it bake for shadows, but not for reflections...
1.jpg
1.jpg (149.9 KiB) Viewed 691 times




Here another test, i place local probe around global one, in shadow area, here what see global one



2.jpg
2.jpg (141.11 KiB) Viewed 691 times
Last edited by mind revolution on Thu Feb 16, 2017 5:42 pm, edited 1 time in total.

Re: [5.3.2] Environment probe/problem

#5
As with previous version's of (V) reflection strength heavily decided by DDNA, (remove the DDNA from slot just to check)

couple things check, Smoothness 255 And in level settings (TIV2) "Use light probes"

All working okay here.

Image


Also I found a new thing needed was after generation of probe I had to click the button and locate the built probe and select it for use in cubemap slot, the engine did not do it for me, is this correct? why did engine not input the cubemap for me? (circled in red)
Entropy Games

Re: [5.3.2] Environment probe/problem

#6
calmdev,your test incorrect, you need reset TOD and give some angle to sun light, so you actually see shadows from your objects.. i have simple reflective material without maps, this ball is just for check cubemap generation... no svogi.. your problem with manual placing cubemap in slot is not on my side, on older version 5.0 - 5.2 have some, i dont remember which one exactly, but not in 5.3..
Last edited by mind revolution on Mon Feb 13, 2017 6:47 pm, edited 1 time in total.

Re: [5.3.2] Environment probe/problem

#8
excreation wrote:"Compile texture from "gamezero\textures\cubemaps\newtest\environmentprobe2_cm.tif", to "d:\appcache\windowstemp\saved games\gamezero\texturecompiler\gamezero\textures\cubemaps\newtest/environmentprobe2_cm/environmentprobe2_cm.dds"
[Warning] Schedule 'Cubemap Texgen Schedule' failed on item 'Cubemap Texgen ScheduleItem'."

then i tried to load the file from game folder by hand, the cubemap actually has been generated,then i loaded it up and it worked! but don't know why it didn't load by engine automatically.


excreation. ^described is exactly what I see and had todo to get enviroment probe to work. And I also noticed the above error msg in console after generation.
Entropy Games

Who is online

Users browsing this forum: drichardson and 1 guest