Page 3 of 4

Re: CRYENGINE 5.4 (Major Release)

Posted: Wed Sep 27, 2017 9:04 am
by excreation
Anyone tried "GI Without Voxels" in new release? seems i can't make it work properly...

Edit:
and i think the demo level attached in doc should be updated for people to catch up with.

Re: CRYENGINE 5.4 (Major Release)

Posted: Wed Sep 27, 2017 10:18 am
by cinnabear
Anyone tried "GI Without Voxels" in new release? seems i can't make it work properly...

Edit:
and i think the demo level attached in doc should be updated for people to catch up with.
"GI Without Voxels" also didn't work in 5.3 from my experience. The last iteration it worked was 5.2.

Re: CRYENGINE 5.4 (Major Release)

Posted: Fri Sep 29, 2017 10:39 pm
by quasarwei
"failed to load material layer shader 'Ping' in material..." console log & class TagPoint not registered with engine
  • Platform: Windows 
    Build: 5.4 as shipped
    Version Number: 5.4.0, build 164
- error messages in log appear when I click on a terrain material in the material editor or change a setting for a submaterial. Sometimes changing a property for a terrain material doesn't update in the viewport and I have to reload the level.
- another separate minor error that I get is when I add a tagpoint to the level. Apparently it's not registered with the engine, because I get a message that says "[Warning] Entity creation failed, class TagPoint was not registered with the engine!"

EDIT:
I fixed the ping error. For some reason, the material layer was set to ping in one of my terrain material files, I just deleted the MaterialLayer block and it fixed all of the errors relating to ping.
I am getting another error regarding invalid surface types. I have a few brush objects and I get the following in the console when I first open up the level:
invalidsurfacetype.JPG
invalidsurfacetype.JPG (109.33 KiB) Viewed 2746 times
ping mat.JPG
ping mat.JPG (169.64 KiB) Viewed 2770 times
this showed up at startup of a level:
ping startup.JPG
ping startup.JPG (27.69 KiB) Viewed 2760 times

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Thu Oct 12, 2017 8:18 am
by quasarwei
Platform: Windows 
Build: 5.4 as shipped
Version Number: 5.4.0, build 164

Undo and Redo keyboard shortcuts don't work. From the menu does, but the shortcut keys don't even though they are bound.

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Thu Oct 12, 2017 7:20 pm
by quasarwei
Sorry about the back to back posts but I feel it's better to have separate posts on different issues, unless a mod says otherwise.

Platform: Windows 
Build: 5.4 as shipped
Version Number: 5.4.0, build 164

underlying material shows up in further LODs when integrating into terrain.

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Wed Oct 25, 2017 6:13 pm
by graf_fridula
Platform: Windows 10
Build: as shipped
Version Number: 5.4.0

Animation track in track view doesn´t work. When I click it the window doesn´t show up like in 5.3 or earlier versions. Is it probably because of the new entity system?
Used entity: advanced animation
Issue.JPG
Issue.JPG (105 KiB) Viewed 2516 times

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Thu Nov 02, 2017 2:32 pm
by cinnabear
i've notice that when soft depth test and POM are both active the self occlusion of POM stops working. Not sure if thats a bug or a limitation but it would be nice to see this fixed

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Thu Nov 02, 2017 2:34 pm
by TAN
Platform: Windows 8.1
Build: as shipped
Version Number: 5.4.0


Advanced Animations Component is simply either broken or has a very unique way that is impossible to figure about without documentation. For a detailed portray of problem please check:

viewtopic.php?f=36&t=4288

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Tue Jan 16, 2018 9:28 pm
by mind revolution
[Cryengine] - Problem with GGX filter type
  • OS: Windows 7
    Build: as shipped
    Version Number: 5.4 build 164
Cryengine have problem with ggx, for some reason this line cm_ggxsamplecount not presented in rc.ini for environmentprobeHDR preset, as the result we have artifacts as you see on images below, with custom cubmaps it much worse. With standart cryengine sky, etc artifacts can be seen only on second reflections of reflection with hight light sources on them. This line help with problem..

Standart Sky
Image
CustomHDRI
Image

Re: CRYENGINE 5.4 Feedback Thread (Major Release)

Posted: Wed Jan 17, 2018 1:00 pm
by HDN
Title: [SANDBOX] - Animation of Ryse's elephant can't be assigned in Mannequin Editor
  • OS: Windows 8.1
    Build: as shipped
    Version Number: 5.4.0 build 164
- Mannequin Editor fails to show the animation of Ryse's elephant. This could be a bug. Check this article for more details. (At first I thought it was my fault so I post that thread to seek help, but now I suspect it's the Engine fault - but there is a chance it could be my fault though)
- Exact steps to reproduce the error: Setup Ryse's elephant as the playable/animated character, you should be stuck at Mannequin Editor.