CryEngine doesn't start!

#1
New to CryEngine, it installed 5.5 P6, but no matter what project i create, it goes right to the splash screen, stucks around CryRenderD3D11.dll and then a error message pops up that says "The editor has crashed and is now in an unstable state! Process with save or no?"

I have directX11, antivirus doesn't interfere with anything, i don't have intel graphics card, i'm using GTX 970, framework installed, all microsoft redistrutables etc.

ALL THREE LOGS:
ce-launcher.log:

Spoiler!  Show


TEXT LOG 2:
editor.log

Spoiler!  Show

TEXT LOG 3:
dxdiag.txt

Spoiler!  Show

Last edited by silentfootsteps on Tue Apr 16, 2019 10:32 am, edited 1 time in total.

Re: CryEngine doesn't start!

#2
/Moved
Moved to build feedback as this is more of a bug report that concerns the engine rather than the launcher
Note: Please either attach text files or wrap your report in spoiler/hidden tags to prevent users from having to scroll for an excessive amount of time.

Can you confirm you have updated your windows to the latest update, as well as your graphics drivers?
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: CryEngine doesn't start!

#4
Very strange, the issue is with the rendering system.
"Rendering device creation failed!"

Do you get a crash submission report dialog show up?
Make sure to submit a crash report so we can try to tackle this internally.

It may be the case that this has been fixed already for the next update but would still like to make sure.
Do you have any issues using 5.4?
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: CryEngine doesn't start!

#6
This is a long shot but perhaps we can get some more information.

Please follow the steps outlined below:

1. Backup the following file to a safe location: C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\bin\win_x64\CryRenderD3D11.dll

2. Delete the following folders/files:
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\user
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\editor.log
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\game.log

3. Download (attached), unzip (with 7zip) and copy the extracted file (CryRenderD3D11.dll) and place it in C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.5\bin\win_x64

4. Try to run the editor. Then Try to run the Game.

5. Upload the log files (Editor.log/Game.log) to this thread, or if you prefer, PM them to me.
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin
Attachments
CryRenderD3D11.7z
(1.86 MiB) Downloaded 6 times

Re: CryEngine doesn't start!

#7
I followed all the steps but the engine still crashes during initializing/loading CryRender at the splash screen.

editor.log

Spoiler!  Show




game.log :

Spoiler!  Show

Who is online

Users browsing this forum: No registered users and 2 guests

cron