Help with Tutorials

#1
I downloaded CryEngine 5.3.2 - build 23, tried to follow the "Getting Started" tutorials but I ran into a problem.

I went into the marketplace and purchased the residential building free asset and the CryEngine GameSDK Sample Project. From the tutorial, I should see the items in the launcher's my asset, but I don't see anything. Did anyone experience this problem as well? Thanks in advance for any tips...

Re: Help with Tutorials

#4
Awesome, logout then log back in worked for me. The assets are there now, thanks!
Same applies to when there is an engine update - if you don't see an update button, log out and log in and the launcher should fully refresh and show the content.

Re: Help with Tutorials

#5
Hey, I am literally having the same problem. I have CRYENGINE 5.3 downloaded under "my engines" and I have the CRYENGINE GAME SDK SAMPLE under "my assets", also download.

When I launch cryengine 5.3 sandbox, I have literally no assets like it shows in the tutorial. The only way I even managed to get those samples and place a tree, is when I manually go into the folder and launch the game sdk sample sandbox. But by doing this I can't end up playing the level I created because it is nowhere to be found. What am I doing wrong here??


-------------> Nevermind, I realized I had to import the actual game sdk to my project. Got it now! :)

02 Getting Started - Project Setup

#6
I'm following the Project Setup tutorial, downloaded the Residential Building assets. The green button only says Downloaded (not Installed - I assume this is a change in version 5.3). I installed into my project via explorer, but when I go to Brush > Objects and any of the Residential Building assets I got dozens of warnings on each about "'mat_xyz' undefined surface type, using mat_default()." Has anyone else run into this?

[Major feature requests, asset installation from the launcher and the ability to interact (drag and drop to add, delete, etc) with assets in the object pane.]

Re: 02 Getting Started - Project Setup

#7
I'm following the Project Setup tutorial, downloaded the Residential Building assets. The green button only says Downloaded (not Installed - I assume this is a change in version 5.3). I installed into my project via explorer, but when I go to Brush > Objects and any of the Residential Building assets I got dozens of warnings on each about "'mat_xyz' undefined surface type, using mat_default()." Has anyone else run into this?

[Major feature requests, asset installation from the launcher and the ability to interact (drag and drop to add, delete, etc) with assets in the object pane.]
Vane

Thank you for the reply on the workflow. This is something we are actively looking into given we know that the ease of cloning an asset into a project and shifting the directories is important to our users. This is a major feature given the movement of the paths and making sure textures dont disconnect. The surface type derives from GameSDK and therefore in a template project they are not registered.

Reading this documentation on matterialeffects you will see how to register or create new surfacetypes in your project and build up to have the same as in GameSDK.

http://docs.cryengine.com/display/SDKDO ... urfaceType

Re: 02 Getting Started - Project Setup

#8
I'm following the Project Setup tutorial, downloaded the Residential Building assets. The green button only says Downloaded (not Installed - I assume this is a change in version 5.3). I installed into my project via explorer, but when I go to Brush > Objects and any of the Residential Building assets I got dozens of warnings on each about "'mat_xyz' undefined surface type, using mat_default()." Has anyone else run into this?
Vane

Thank you for the reply on the workflow. This is something we are actively looking into given we know that the ease of cloning an asset into a project and shifting the directories is important to our users. This is a major feature given the movement of the paths and making sure textures dont disconnect. The surface type derives from GameSDK and therefore in a template project they are not registered.

Reading this documentation on matterialeffects you will see how to register or create new surfacetypes in your project and build up to have the same as in GameSDK.

http://docs.cryengine.com/display/SDKDO ... urfaceType
Thanks for the explanation. I figured the feature request would be a lot of work. What about the tutorial? I’m following it verbatim using the downloaded CryEngine assets the tutorial is referring to and am getting all those errors. The Project Setup tutorial is one of the first, and getting derailed that quickly was extremely discouraging.

Who is online

Users browsing this forum: No registered users and 3 guests