Sandbox eating 50% CPU time with totally empty level

#1
Hi,

I'm a total noob with CryEngine so please forgive me if this is not the right place for this question.
I just downloaded CE today (latest version) and created an empty C++ project.
Sandbox starts and since then fully uses 2 of my 4 CPU cores (50% computing power of my notebook) while having done nothing yet in the editor.
It drops to 25% (1 core only) if I focus another window (Sandbox window goes background) but goes back to 50% if I just refocus its window.
Haven't done anything at all in the editor and nothing is rendered.
Searching on the internet I found an old thread somewhere else with similar problem solved adding to editor.cfg the line ed_MissingAssetResolver = 0, which I did to no avail.
My OS is Windows 7 64 bit.

Attaching an image to show the issue:
https://imgur.com/a/UL7UapX

Thanks for any help.

Re: Sandbox eating 50% CPU time with totally empty level

#3
Hi,
Sandbox will reduce cpu usage after sometime while using it.You can just reduce graphic usage using sandbox through Display->Graphics->Low.
And you can turn off ocean via Display menu of the Perspective windows and tik off the ocean under the hide the category list.
In my case Windows 10 is best for CE5.5 because windows 10 manages the ram usage by reducing size while minimize the sandbox window.Let the sandbox little time to allocate their sources and then sandbox will reduce cpu and ram.I have i3 dell laptop with 4gb ram and 2gb shared vga ram.
This is a screenshot of mine while using sandbox
sandbox.png
sandbox.png (451.95 KiB) Viewed 634 times
Cheers!
Vishwajith Weerasinghe

Re: Sandbox eating 50% CPU time with totally empty level

#4
Hi,
Sandbox will reduce cpu usage after sometime while using it.You can just reduce graphic usage using sandbox through Display->Graphics->Low.
And you can turn off ocean via Display menu of the Perspective windows and tik off the ocean under the hide the category list.
In my case Windows 10 is best for CE5.5 because windows 10 manages the ram usage by reducing size while minimize the sandbox window.Let the sandbox little time to allocate their sources and then sandbox will reduce cpu and ram.I have i3 dell laptop with 4gb ram and 2gb shared vga ram.
This is a screenshot of mine while using sandbox
sandbox.png
Cheers!
Minimum:

OS (to run Game): Windows 7, 8.1, 10 (32-bit or 64-bit)
OS (to run Editor): Windows 7, 8.1, 10 (64-bit only)
Processor: Intel Dual-Core min 2GHz (Core 2 Duo and above) or AMD Dual-Core min 2GHz (Phenom II X2 and above)
Memory: 4 GB RAM
Graphics: NVIDIA GeForce 450 series or AMD Radeon HD 5750 series or higher (minimum 1 GB dedicated VRAM GDDR5)
DirectX: Version 11
Hard Drive: 8 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers

Recommended:

OS (to run Game): Windows 7, 8.1, 10 (64-bit)
OS (to run Editor): Windows 7, 8.1, 10 (64-bit)
Processor: Intel Quad-Core (i5 2300) or AMD Octo-Core (FX 8150)
Memory: 8 GB RAM
Graphics: NVIDIA GeForce 660Ti or higher, AMD Radeon HD 7950 or higher (minimum 2 GB dedicated VRAM GDDR5)
DirectX: Version 11
Hard Drive: 8 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers
Image

Re: Sandbox eating 50% CPU time with totally empty level

#5
Hi,
Sandbox will reduce cpu usage after sometime while using it.You can just reduce graphic usage using sandbox through Display->Graphics->Low.
And you can turn off ocean via Display menu of the Perspective windows and tik off the ocean under the hide the category list.
In my case Windows 10 is best for CE5.5 because windows 10 manages the ram usage by reducing size while minimize the sandbox window.Let the sandbox little time to allocate their sources and then sandbox will reduce cpu and ram.I have i3 dell laptop with 4gb ram and 2gb shared vga ram.
This is a screenshot of mine while using sandbox
sandbox.png
Cheers!
Minimum:

OS (to run Game): Windows 7, 8.1, 10 (32-bit or 64-bit)
OS (to run Editor): Windows 7, 8.1, 10 (64-bit only)
Processor: Intel Dual-Core min 2GHz (Core 2 Duo and above) or AMD Dual-Core min 2GHz (Phenom II X2 and above)
Memory: 4 GB RAM
Graphics: NVIDIA GeForce 450 series or AMD Radeon HD 5750 series or higher (minimum 1 GB dedicated VRAM GDDR5)
DirectX: Version 11
Hard Drive: 8 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers

Recommended:

OS (to run Game): Windows 7, 8.1, 10 (64-bit)
OS (to run Editor): Windows 7, 8.1, 10 (64-bit)
Processor: Intel Quad-Core (i5 2300) or AMD Octo-Core (FX 8150)
Memory: 8 GB RAM
Graphics: NVIDIA GeForce 660Ti or higher, AMD Radeon HD 7950 or higher (minimum 2 GB dedicated VRAM GDDR5)
DirectX: Version 11
Hard Drive: 8 GB available space
Sound Card: DirectX Compatible Sound Card with latest drivers
Yes this is the recommendation of the crytek team for CE.I have only 64 bit win 10 4gb ram intel HD graphics and 2 gb shared vga ram.But I built a game and it works fine in my laptop. :D
Vishwajith Weerasinghe

Re: Sandbox eating 50% CPU time with totally empty level

#6
Hi Guys,
thanks to all for your replies and suggestions.

Anyway I would like to stress the point that I have no sky, ocean or anything else rendered in the Sandbox editor because I just created an empty project and done nothing at all in it.

In spite of that, as you can see in the attached screenshot (which shows my totally empty level in the background too) , the CPU usage is as high as I already said making my PC nearly unusable.
Btw, my notebook is 4 core i7, 16 Gb ram, 1 Tb HD and Nvidia GTX Card so above the minimum requirements.
I'll shortly try CE on another notebook with 8 i7 cores, latest generation, 16 Gb ram, 256 Gb SSD + 1Tb HD, Nvidia GTX 1050, MS Win10 and see if Sandbox has the same issue.

Frankly it smells more of a bug than an intended Sandbox behavior.
In fact as such it was treated in this old 2013 Cryengine forum https://www.cryengine.com/community_arc ... &t=114274 , the culprit being the asset loader spinning the CPU while trying to load non existing assets and solved editing the editor.cfg.

It looks like a similar issue but caused by something else since that solution hasn't solved my scenario.

What is your experience with CE Sandbox CPU usage when idle and especially with a just created and totally empty new project?
What should I consider as normal, in other words?

Just in case, where to ask or filing a bug report?

Thanks all again.

Re: Sandbox eating 50% CPU time with totally empty level

#7
Hi there, this does seem odd.
I cannot personally reproduce this issue, on a 4 core system it goes from 40% in focus to below 20% out of focus.

You can submit bug reports on our GitHub issues tracker:
https://github.com/crytek/cryengine/issues

If you can provide as much detail as possible and reproducible steps it will help us greatly in tackling this issue.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: Sandbox eating 50% CPU time with totally empty level

#8
Hi Cry-Flare,

thanks for replying.

If those cpu usage figures you provided are to be intended when you have a just created and untouched empty project in Sandbox then there could be something on my OS, AV and / or installed software configuration which may bias my notebook's cpu usage higher, even if in the task manager it looks the CE Sandbox alone to be heavy using the cpu time.
Nonetheless some driver and or other software may affect the CE behavior for cpu usage.
I have to make more experiments to try to understand better.
The cpu fan after the first minute goes to its maximum speed and the notebook becomes sluggish.
I don't know, it might be due to my specific CE installation, since I didn't install many of the optional SDKs, i.e. like Substance .

I'll make a bit more experimentation, using also that other more powerful notebook I spoke about to make a comparison.

I'll let you know,

thanks very much.

Re: Sandbox eating 50% CPU time with totally empty level

#9
No problem, the more accurate your reproduction and information on the issue the better we can investigate any potential causes so thanks for taking the time to troubleshoot this problem on your side. Optional SDKs are not necessary for performance and should not affect the results.

One thing I would stress the most would be;
Do a Clean-Boot with windows (disabling any and all startup programs, services and non essential scheduled tasks). There are several guides on performing a full clean boot, of course, the best option is a freshly installed and updated operating system. Though being a laptop this might be difficult to pull off without a spare/secondary drive.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 2 guests