Problem with Alpha Channel

#1
I've tried making . PNG files -- that possess a 'Transparent' layer -- It doesn't work. I watched the CRYENGINE Youtube PFX 2 Particle Tutorial, and I tried following it …. He adds an 'Appearance : Blending' To the Particle and, Sets it to 'Additive', not 'Alpha'. This works but there is no Darkness in the Smoke-particles, though there is in the Smoke-particles I painted (see Added Picture). How can I make Dark smoke, in CRY ENGINE 5 ??

It's here >>> https://youtu.be/mzaAtwtko7E?t=2112 (Skips to Correct Time <3 <3)

.
Attachments
Smoke 002614875.png
Smoke 002614875.png (22.42 KiB) Viewed 637 times
Smoke 0026145.png
Smoke 0026145.png (22.42 KiB) Viewed 637 times
Smoke 002614875.png
Smoke 002614875.png (22.42 KiB) Viewed 637 times

Re: Problem with Alpha Channel

#3
There's a long time since i worked with cryengine so i don't remember what blend options it has for particles but afaik additive like the name says adds the color unto the existing colors, so the brighter the color, of the blend texture, the more visible the effect, additive blending is mostly used to make glowing textures, like those simulating small lights in a suit or something. Perhaps what you want to do is use multiply or modulate ( if available ) but they work in reverse the brighter the color the less visible is the effect.

Imo if you want dark spots and bright spots then you will need to use two blend "stages" in your particle material one additive stage to bring out the whites and one multiply or modulate stage to make the darker spots stand out.

Who is online

Users browsing this forum: No registered users and 1 guest