Cgf does not show in asset browser

#1
Hello all, I have made a mesh to use as a shell casing in a particle effect ejecting from a custom weapon I am working on. I cannot for the life of me figure out why my cgf exported from 3ds max is not showing up in my objects folder. It does not show up in the asset browser in the main ui either (I assume its the same issue causing this). It does however show up in the brushes category and I have no issue placing it in the scene from there. Whatsmore, I have some assets I made a few months ago for another project that are perfectly visible in the asset browser and the cgf picking dialog for the particles, and they work in game, although its mostly furniture I modeled lol. I am really baffled at the cause behind not being able to see or select my custom .cgf files from max... The folder that the asset is saved in is under /objects/weapons/ammo/shells... which to my knowledge should be fine.

Any ideas/input would be much appreciated!

-Yamanash


Edit: Got it working as it should now. It had something to do with 3ds max and the RC not communicating properly I believe. Clearing everything out of the directory, making a new 3ds max scene file and re-exporting eventually solved the issue.

Re: Cgf does not show in asset browser

#2
Thanks for providing your solution.

If you encounter similar issues in the future, please know that you can disable the "Asset Picker" functionality and use file-system dialogs to import/open files by setting "ed_enableAssetPickers" to 0 via the console pane. Some functionality may be limited by this change, though.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 1 guest