AI Bots in Multiplayer Not Respawning

#1
With several of the maps I've been working on it has been suggested to add some AI to keep things interesting with fewer players. With that in mind, I created 3 waves of AI to respawn during an instant action round.

The first wave of 2 come in on a corner of the map and criss-cross through the alleys. The second wave of 2 patrols around the main streets. The 3rd is just 1 AI that stays up on a balcony to shoot from above.
TheTown_AI_Map.jpg
Map showing AI Waves and Navigation
TheTown_AI_Map.jpg (271.27 KiB) Viewed 1823 times
I would like them to continually respawn once all are dead and a short time delay. My Flow graphs are below. They work properly in Editor and Single Player Modes. But they do not respawn in Multiplayer Mode. There is a similar flowgraph for each wave attached to the AI Grunt that Holds the Formation.
AI Respawn_01.jpg
AI FLowgraph Part 1
AI Respawn_01.jpg (641.87 KiB) Viewed 1823 times
AI Respawn_02.jpg
AI FLowgraph Part 2
AI Respawn_02.jpg (787.65 KiB) Viewed 1823 times
The AI behave properly according to their Sequences, and they Spawn the first time around. They just don't respawn once dead.

What am I missing/doing incorrectly?

Re: AI Bots in Multiplayer Not Respawning

#3
instead of ai wave have you tried just spawning separate ai on a time delay loop



When that didn't work I also added this flowgraph to the main game flowgraph housed in a Spawn Point to try and reset the AI once dead so they would respawn. It did not work either.
AI Respawn_03.jpg
AMD RYZEN 5 2600 OC 4.2, ASROCK 570 PHANTOM D GAMING OC 1325

Who is online

Users browsing this forum: No registered users and 1 guest

cron