CE5.3.3 on Ubuntu 16.04

#1
Hi all,
After more than a year I like to try the CE once again :)

I've downloaded the zip-file from git, unzipped it and can compile it (after I made some "bug-fixes")
for example: (the g++ stops; because of: treat warnings as error at Code/CryEngine/Cry3DEngine/GeomCacheRenderNode.cpp:285:54
memcpy(hashableData, pCREGeomCache, sizeof(pCREGeomCache));
but this solves the problem:
size_t helper = sizeof(pCREGeomCache);
memcpy(hashableData, pCREGeomCache, helper);
by the way, compiling works fine so far for: debug profile release with gamesdk and gamezero

If I try to launch the game I get many warnings about missing textures and such.
Last message from game.log is: *** Init system render resources *** (here the log ends )

Meanwhile I have downloaded and installed the CE_Launcher things (on Win10) and I have downloaded the GameSDK - Sample too.

My question is : Where do I need to copy the GameSDK things to, to get the ducks in a row :) ?

P.S. what to do, to upload the "game.log" (It may be helpful for U to help me further)


One thing I have forgotten :)
greetings CryPatsy (she helped me a lot last year; hope you are well ) :)

Re: CE5.3.3 on Ubuntu 16.04

#2
Hi tuxfan,

I'm doing pretty well thanks :) Sorry for not getting back to you sooner on this - I've been on holiday and I'm just now catching up.

I'll go through the process of setting up GameSDK and write you a neat summary once I'm done (it's been a little while since I've done it and I don't want to give you outdated instructions).

Who is online

Users browsing this forum: No registered users and 1 guest