Stuck on Medium spec with oculus

#1
I just recently got my new Oculus CV1 installed and am having a few issues.

First, I cannot seem to be able to set the graphics quality higher than medium in the editor. Havent tried the full game launcher yet, but it for sure wont take high or very high in the editor now. I can click high or very high, but it just reverts back to medium. Does having the oculus drivers installed limit the maximum spec?

Second, the skybox and a lot of particle stuff renders differently on the right or left eye. I set the environment editor to accelerate the time of day so I could see the different lighting conditions on my test level and immediately noticed the problems with the sky. One eye will be showing dark night with stars, while the other eye still has a bright sun lit sky. sometimes it settles and both eyes see the same condition, but then at night the stars are out of position from the right to the left eye.
Is this fixed in 5.4? I tried to get 5.4 preview working but it was a massive fail (probably on my part), I had to wipe it all clean and start over. I'll just wait for the actual 5.4 release.

I am using engine v5.3 and game SDK5.3
Graphics card Radeon R9 295X2
16G ram and an 8 core AMD FX9590 running at 4.72Ghz
I dont think my system is the limiting factor here.

Re: Stuck on Medium spec with oculus

#5
With VR you have to think differently. Handling menus in a different way. First thing i would do is to ditch the old SDK menu if you are using that, it's not made for VR, then simplify things. Just have simple boxed text labels in front of you. Good thing with Flash in CRYENGINE is that you can hot-reload them via cvars if the flash asset has changed. Which again means you don't have to close the Game Launcher to see the changes. Put these two into your .cryproject file.

Code: Select all

gfx_FlashReloadEnabled = 1 gfx_FlashReloadTime = 1
Check out the docs here on resetting and centering the HMD :
http://docs.cryengine.com/display/CEMANUAL/VR+Support
http://docs.cryengine.com/display/CEMAN ... culus+Rift

Also make sure you are using the newest Oculus SDK and drivers.

Who is online

Users browsing this forum: No registered users and 1 guest

cron