Problem with Oculus Rift and First Person Game Plugin

Hi everyone.
I'm currently having an issue with the Oculus Rift and CryEngine. It's basically the first time that I try to use the Rift with the engine so I don't have any experience with it.

I just tried to activate it with the default Firt Person Shooter C++ Plugin. So I just created an entirely new and fresh Project.
Then I went into the Code and just changed the Camera inside player.h to a VR Roomscale Camera. Inside the player.cpp I of course also changed the camera component to a roomscale camera. Builds without any error.

Next I checked the documentation for the VR setup and followed the steps there (updating drivers, allowing unknown sources inside the Oculus Launcher, adding the VR Plugin to the game project file, creating a system.cfg inside the project folder with sys_vr_support=1).

If I now jump into game mode, it just starts as normal without any VR.
Inside the Oculus Rift I can see that it wants to start the "Game Launcher" Application but it just says that it's loading no matter how long I wait.
I can now open the console while running the game mode and type in sys_vr_support=1. This just makes the camera jump to the bottom of the player entity. However now the camera reacts to the orientation of the Rift and rotates properly. It still doesn't render to the rift or anything.

Can anyone please help me out here.
Thanks and have an nice day.
- Jannis

Who is online

Users browsing this forum: No registered users and 1 guest