Page 1 of 1

CMake errors for CRYENGINE source code

Posted: Sat Feb 09, 2019 6:39 pm
by purya3
Hi guys😃🖐!

I want to edit CRYENGINE source code . According to " https://docs.cryengine.com/display/CEPR ... ource+Code" texts, I did all the steps.

When I click on the " Configure " button , the following errors appear for me :
CMake Warning at Tools/CMake/BuildSandbox.cmake:2 (message):
FBX SDK (2016) is required to build Sandbox. Download it from
https://www.autodesk.com.
Call Stack (most recent call first):
Tools/CMake/Build.cmake:43 (include)
CMakeLists.txt:3 (include)


CMake Error at Tools/CMake/Build.cmake:74 (get_property):
get_property could not find TARGET Sandbox. Perhaps it has not yet been
created.
Call Stack (most recent call first):
Tools/CMake/Build.cmake:128 (generate_unit_test_targets)
CMakeLists.txt:3 (include)


With respect to the first error, I'm sure fbx sdk is install in my computer !

Re: CMake errors for CRYENGINE source code

Posted: Sun Feb 10, 2019 6:43 am
by game_dev5
Hi.
I haven't built source code with sandbox editor. It needs some third party software installed.
Are you sure you need to build sandbox? If you exclude it, you can build the source code easily.

Re: CMake errors for CRYENGINE source code

Posted: Wed Feb 27, 2019 4:13 pm
by Cry-Flare
As game_dev5 explained, Sandbox requires the FBX SDK.
You can download the FBX SDK for free from Autodesk.
You will also need to install the MFC components for Visual Studio.

If you do not need to compile Sandbox, then you can untick this option in the CMake GUI.

If you need help installing the FBX SDK feel free to come back here and let us know how far you got/what you need to know.