Page 1 of 1

Bought free items won't show in "My Assets"

Posted: Tue Dec 11, 2018 3:55 pm
by butaixianran
To learn cryEngine, bought some free items, but they won't show in "My Assets" of Account Management.

Also, I can't download any of them from cryEngine launcher.

In marketplace, those items are displayed as "Your already bought this product".

How should I fix this problem?

thanks

---------------
Update:
Well, after 24 hours later, I re-checked my lanucher, still can't download them.

But, a few minutes before, I re-check lanucher again, suddenly all those products show up and I can download them from launcher now.

I did nothing. I have no idea why it works now.

"My Assets" of Account Management on website is still empty though.

Re: Bought free items won't show in "My Assets"

Posted: Fri Jan 04, 2019 5:05 pm
by Cry-Flare
Hi there, glad it was solved.
If you encounter this issue again you may want to logout, close, then open and login to the launcher.

The My Assets on the website is your own asset submissions.