Serious Issue w/ CRYENGINE Launcher Asset Downloader

#1
I cannot download any asset from the launcher's Asset window no matter how much I try. I always get the following prompt exactly twice for every asset I try to install.

error.JPG
error.JPG (161.59 KiB) Viewed 329 times


Also worth mentioning is that the engine itself (5.4) downloads without a problem suggesting there isn't any problem with the internet connection and its context with the launcher. Tried reinstalling the launcher already as well.

This is seriously turning me off from learning CRYENGINE as I have nothing to begin with, no concrete example. I could live with having to download these assets from different locations and installing manually but I don't even seem to have that option. Please come up with a resolution, and quick.

Re: Serious Issue w/ CRYENGINE Launcher Asset Downloader

#4
Please go to "%LOCALAPPDATA%\CRYENGINE_Launcher" in your windows explorer and provide the file ce-launcher.log from there.

In the mean time, try the usual (or confirm exactly what you have tried):
1. Troubleshooting your network connection in windows.
2. Temporarily disabling your anti virus and firewall.
3. Restarting your network devices.
4. Launching the CE Launcher with administrative privileges.
5. Make sure the folder "C:\Program Files (x86)\Crytek" and ALL subfolders there in are owned by the current user (or at least, the current user has rights to read/modify/execute).

good luck
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Re: Serious Issue w/ CRYENGINE Launcher Asset Downloader

#5
uniflare wrote:Please go to "%LOCALAPPDATA%\CRYENGINE_Launcher" in your windows explorer and provide the file ce-launcher.log from there.

In the mean time, try the usual (or confirm exactly what you have tried):
1. Troubleshooting your network connection in windows.
2. Temporarily disabling your anti virus and firewall.
3. Restarting your network devices.
4. Launching the CE Launcher with administrative privileges.
5. Make sure the folder "C:\Program Files (x86)\Crytek" and ALL subfolders there in are owned by the current user (or at least, the current user has rights to read/modify/execute).

good luck


Thanks for the suggestions. Unfortunately none of those solve the issue. Here I've appended the log file as well. I can't seem to figure out the issue. It seems to be something called a PLUGERR_DOWNLOAD_NETWORK_ERROR. I have no idea what that means. Hope this helps in some way.

Btw your beginner's guide series is a rather pleasant, accidental encounter of the day. The CryEngine Source Code stuff is very helpful indeed.
Last edited by viracocha on Tue Sep 26, 2017 12:17 pm, edited 1 time in total.

Re: Serious Issue w/ CRYENGINE Launcher Asset Downloader

#6

Spoiler!  Show

Last edited by viracocha on Tue Sep 26, 2017 7:28 pm, edited 1 time in total.

Re: Serious Issue w/ CRYENGINE Launcher Asset Downloader

#9
Ok so I tried to download using a separate internet connection and it seems to have worked. But this is using my mobile data which is limited and not at all geared for heavy duty downloads. I'll attach my log file to show how it downloads in one connection and doesn't in the my regular internet connection.

Now if only I could connect my launcher to the internet through a proxy server. Can I set my launcher to connect as such?

(I'll spoiler collapse the previous comment for its irritating length)
Attachments
ce-launcher.rar
i just renamed it to .txt cause the site wasnt accepting .log for some reason. And didnt do the same for .txt but did accept .rar!
(3.46 KiB) Downloaded 3 times

Re: Serious Issue w/ CRYENGINE Launcher Asset Downloader

#10
Ok so I still don't exactly know whats wrong but at least I've narrowed down the problem:

  • The problem it seems is to do w/ few people having a certain type of firewall behind their internet connection
  • Mine is the internet provided by the university
  • However the launcher itself connects fine to the internet during login as well as during the download of the engine
  • Using some VPN circumvents this problem, some don't, as it didn't work with Softether VPN but worked with Betternet (was my last resort due to its sketchy plans, but hey, at least it worked)
  • There is a different way of connecting to the servers for downloading the engine and assets respectively
  • One way is liked by the router or the connection protocol (or whatever is the correct term), the other not so much

This is in a very layman language I agree but that is the extent of me. Having to use VPN for downloading Assets is not very fun. I hope the team sorts this one out so that the Assets can be downloaded without a hitch, like the engines do. It would've been trivial if I was the only one affected. However it seems there are a lot more than I first anticipated. It is worth fixing imo. But hey, whatever the team thinks is best is fine with me as long as the engine itself is supported unconditionally, with as much love and documentation :)

PS. But please do consider ;)

Who is online

Users browsing this forum: No registered users and 1 guest