Cryengine cant generate solutions

Good day,

I have installed cryengine on my m.2 drive on the E disk in a new folder and now I cant generate solutions for Visual Studio. I have tried deleting cryengine completely and reinstalling it but when I do I cant install it on the c drive in program files 86 without issues. Ive done this about 3 times already and I am trying to figure out how to get the default settings for all the folders.

Re: Cryengine cant generate solutions


Please provide more information regarding your issue. Saying you have a problem and are getting errors, without specifying what errors you are getting, or what is happening besides it's not working, doesn't provide enough information for anyone to troubleshoot and help you.
Hey I'm think having the same problem, when right clicking any cryengine. Cryengine is installed at AppData\Local\Programs\CRYENGINE Launcher\Engines\crytek\cryengine-56\5.6.7


Re: Cryengine cant generate solutions

Ok here is the simple version..
1. I installed the cryengine launcher
2. I am following the breeze tutorial on youtube video number 5 for character contoller
3. On the character controller tutorial it says generate solutions on your game icon
4. when I do that it does not generate solutions
5. It asks how do I want to open it and gives me a location
6. if i follow that location it still does not open or generate solution therefore I cant continue with the tutorial
7. So far the rest of cryengine works. I can create projects, levels and assets
8. The game icon is white and not blue as it was when I used cryengine a month ago
9. I have tried uninstalling and reinstalling in the default locations and nothing as worked
10. I have attached photos
cryproblem.jpg (324.86 KiB) Viewed 8719 times
cry2.jpg (215.62 KiB) Viewed 8719 times

Re: Cryengine cant generate solutions

Thank you for the detailed explanation and reproduction steps. It seems your CRYENGINE version isn't registering, strangely. I am currently having this investigated internally.

To fix this for now, you can go to the file location of your current engine version. Using the launcher in your engines tab, click the hamburger menu for the engine version you're working with, and select reveal in explorer. From there, go into Tools > CryVersionSelector > install.bat. Double clicking that should register your engine version.

If afterwards, your .cryproject is still white, right click on it, and select properties. Click on the change button to the side of opens with. Go down to find an app on your pc, and navigate to your engine folder like above, and go to Tools > CryVersionSelector > bin > cryselect > cryselect.exe

Doing that should allow you to Generate Solution. Let me know if the issue still persists.

Re: Cryengine cant generate solutions

Good Afternoon,

Thank you for the response and I am here to say that it worked! To my surprise however something strange happened. On my desktop all i needed to do was register the engine version and everything went back to normal but on my laptop I had to do the second part with going into the properties and changing the icon and then resetting the computer. All in all I can move forward thank you very much I appreciate this greatly!

Who is online

Users browsing this forum: No registered users and 1 guest