Page 1 of 1

Can't enable/disable particle effects through FG!

Posted: Tue May 26, 2020 8:44 am
by dev123
Need to enable/disable particle effects through FG. Tried hard searching for the Entity:ParticleEffect node, but could not locate it anywhere. Even the Effects:SpawnParticleEffect node doesn't do anything!
Though in debug mode things start firing into the input ports, but nothing visible happens in the level! Left with no option, i used the cvar e_particles to switch my pfx on and off through FG and now using layer switching to hide and unhide my pfx. Are the nodes deprecated in the latest version of the engine? Please help, need to get this pfx thing up and running!

Re: Can't enable/disable particle effects through FG!

Posted: Tue May 26, 2020 2:53 pm
by VascotiaStudios
Are you using the Particle trigger in the old Entity system or the new component system (for usage with c++ and schematyc?

What engine version are you using? Where is the fg screenshot?

Re: Can't enable/disable particle effects through FG!

Posted: Thu May 28, 2020 5:59 am
by dev123
Using CE 5.6.5- Build 30 and gameSDK project.
Here's the FG setup:
linga_bolt_FG_capture.JPG
linga_bolt_FG_capture.JPG (90.4 KiB) Viewed 961 times
Another shot of what i'm trying to acheive:
linga_bolt_capture.JPG
linga_bolt_capture.JPG (146.87 KiB) Viewed 961 times
Shiva linga will show ray, only on correct orientation of the linga and the pedestal on which it sits.
Using the logic:AND node to accomplish this, but works only once! (the reason i chose to add a Timer:Delay node to display it for a few secs and disappear)
That is, if i keep rotating the pedestal and the linga further on, the bolt wont show up again, even when the conditions are met.
No clue as to why this logic won't work!

Re: Can't enable/disable particle effects through FG!

Posted: Thu May 28, 2020 1:09 pm
by gigilulu
While the particle effect is selected into the scene, r click in the fg editor and choose "Add Selected ..."

Re: Can't enable/disable particle effects through FG!

Posted: Thu May 28, 2020 4:24 pm
by dev123
When i drag and drop my pfx from the PE2(Wavicule) into the level and in FG (right-click) and add selected entity, i get this:
Bolt_pfx_entity_FG.JPG
Bolt_pfx_entity_FG.JPG (11.64 KiB) Viewed 900 times
... and not the Entity:ParticleEffect node like this:
pfx_entity.JPG
pfx_entity.JPG (15.45 KiB) Viewed 900 times

Re: Can't enable/disable particle effects through FG!

Posted: Thu May 28, 2020 7:15 pm
by VascotiaStudios
Thats becouse you are using the Particle Component and not the Particle Entity. The new Component system is not supported by the old Flowgraph system.

Have you installed the scripts.pak from the old GameSDK? That will give you access to the legacy entity system which works fine with Flowgraph.

The Component system will work with Visual Scripting coming with CRYENGINE 5.7.

Re: Can't enable/disable particle effects through FG!

Posted: Fri May 29, 2020 2:33 am
by dev123
Hey thanx a ton both lavizh and gigilulu for ur prompt feedback!
Was wondering why's this so. And now i get it!
Will download an old archived version of gamesdk and install the scripts.pak and try. 8-)