Page 1 of 2

Bot Sound \ FlowGraph

Posted: Tue Apr 07, 2020 8:52 am
by breef_ua
Hello. There was such a problem when I try to tie sounds to Bot through the flow graph. I bind playing sounds from the Orange output (Yellow color photo). Through the Any node, I bind a repeat action with a timing of 5 seconds (Black color photo). Then, with the help of Any, he tied the Green and Red outputs to the stop of these audio triggers (Blue color photo). The problem is that the sounds of the Orange alarm do not stop when the Green and Red alarm occur. They play on. Most likely, the problem lies in the Any node, which I did in the beginning and looped the action. But I just don’t understand how otherwise these triggers can be looped. What can be done in this situation?
Image

Re: Bot Sound \ FlowGraph

Posted: Tue Apr 07, 2020 1:11 pm
by grb1212
do you need to set a stop trigger file, i would have to ask my team member that does audio

Re: Bot Sound \ FlowGraph

Posted: Wed Apr 08, 2020 7:23 am
by breef_ua
do you need to set a stop trigger file, i would have to ask my team member that does audio
That would be good

Re: Bot Sound \ FlowGraph

Posted: Wed Apr 08, 2020 6:55 pm
by Cry-Thomas
Can you clarify following for us?

1) What exact engine version do you use and which project (GameSDK / templates / something custom)
2) Which audio middleware are you working with and what's the exact version?

Re: Bot Sound \ FlowGraph

Posted: Thu Apr 09, 2020 7:11 am
by breef_ua
Can you clarify following for us?

1) What exact engine version do you use and which project (GameSDK / templates / something custom)
2) Which audio middleware are you working with and what's the exact version?
GameSDK 5.6 \ CRYENGINE 5.6.5 \ Audio Control Editor (SDL Mixer 2.0.4).

Re: Bot Sound \ FlowGraph

Posted: Fri Apr 10, 2020 8:54 am
by Cry-Thomas
Any chance you can share the setup with us? I can try and take a look.

Re: Bot Sound \ FlowGraph

Posted: Fri Apr 10, 2020 9:39 am
by breef_ua
Any chance you can share the setup with us? I can try and take a look.
Setting what? Sounds in Audio Control Editor (SDL Mixer 2.0.4).?

Image

Re: Bot Sound \ FlowGraph

Posted: Fri Apr 10, 2020 9:42 am
by Cry-Thomas
- the flowgraph setup
- the ace setup plus involved audio files

Re: Bot Sound \ FlowGraph

Posted: Fri Apr 10, 2020 9:53 am
by breef_ua

Re: Bot Sound \ FlowGraph

Posted: Fri Apr 10, 2020 12:00 pm
by Cry-Thomas
it seems like that the Time:Delay node keeps working, you'll have to stop that delay as well