Page 1 of 1

Not getting "release" files after compiling CryEngine

Posted: Mon Sep 30, 2019 8:05 am
by guzzo
Hi,
After compiling the Cryengine with Visual Studio I'm not getting the files I need for the game in the "Release" folder as you can see here below.
I've compiled the engine first with "Debug" and then with "Release" in Visual Studio.
And here is my folders after compilation:
release.png
release.png (44.08 KiB) Viewed 8864 times
x64.png
x64.png (120.86 KiB) Viewed 8864 times

What is happening? Can you help please?

Re: Not getting "release" files after compiling CryEngine

Posted: Tue Oct 01, 2019 9:40 am
by guzzo
I've noticed that the output folder of the projects in Visual studio are not in "release" folder. Is this a Cmake error?
visual_output.png
visual_output.png (114.04 KiB) Viewed 7131 times

Can anyone help please? I'm stuck.

Re: Not getting "release" files after compiling CryEngine

Posted: Thu Oct 10, 2019 2:02 pm
by Cry-Flare
It is the state of the CMake scripts during 5.4.
All binaries output in any configuration go into the default win_x64 folder.

Are you having issues compiling? (Errors)
It appears all the binaries are being produced.

Re: Not getting "release" files after compiling CryEngine

Posted: Thu Oct 10, 2019 2:35 pm
by guzzo
It is the state of the CMake scripts during 5.4.
All binaries output in any configuration go into the default win_x64 folder.

Are you having issues compiling? (Errors)
It appears all the binaries are being produced.
Thank you for helping.
no errors, but the file "CryScaleformHelper.dll" is not produced and without it all the ui is not showing.
Do you know how I can produce it?

Re: Not getting "release" files after compiling CryEngine

Posted: Thu Oct 10, 2019 4:52 pm
by Personwithhat2
When building in CMake, make sure to check scaleform helper and it should build :)

Re: Not getting "release" files after compiling CryEngine

Posted: Thu Oct 10, 2019 5:30 pm
by guzzo
When building in CMake, make sure to check scaleform helper and it should build :)
Yes I've checked it but it doesnt build :(

Re: Not getting "release" files after compiling CryEngine

Posted: Wed Oct 16, 2019 8:24 am
by Cry-Flare
Hey there,

As long as you don't modify CryCommon or other interface code, then you can use the DLL that is shipped with the CRYENGINE Launcher. You cannot build the CryScaleformHelper.dll yourself without access to the Scaleform SDK.

We provide a release binary for this purpose. By default, it should reside in the following location:
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64_release

Re: Not getting "release" files after compiling CryEngine

Posted: Wed Oct 16, 2019 11:59 am
by guzzo
Hey there,

As long as you don't modify CryCommon or other interface code, then you can use the DLL that is shipped with the CRYENGINE Launcher. You cannot build the CryScaleformHelper.dll yourself without access to the Scaleform SDK.

We provide a release binary for this purpose. By default, it should reside in the following location:
C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\CRYENGINE_5.4\bin\win_x64_release
Thanks Flare,
yes I've noticed that file in the past and I've been using it for my release build. I've tought that some problems with my release could be related to CryScaleformHelper.dll that was not been compiled, but if you say this, it could not be the cause of the problems I'm having, as I've not edited the CryCommon.
Can you help me in the other thread please as the problem seems related to the encryption?
viewtopic.php?f=40&t=12146&p=26079#p26079