Page 1 of 4

cryengine5.6 low fps issue.

Posted: Wed Sep 04, 2019 8:56 am
by lidingxing
i find the fps is lower than old version(cryengine5.5) in the same level?
fps (cryengine5.5,woodland):about 220
fps (cryengine5.6,woodland):about 120
anyway i can increase fps????
fps_low1.PNG
fps_low1.PNG (2.56 MiB) Viewed 4952 times
fps_low2.PNG
fps_low2.PNG (2.8 MiB) Viewed 4952 times

Re: cryengine5.6 low fps issue.

Posted: Fri Sep 06, 2019 4:18 pm
by Cry-Flare
Hi there,

This is difficult to determine the cause from pictures alone.
Perhaps the first thing to check would be the CVars. You can use the command:
DumpVars

This will dump all CVars to a text file called consolevars.txt, you can do so for both versions of the engine in the same level and compare them using a diff tool (such as Notepad++ Compare Tool).
This may give some insights into what is different and what you can do.

Re: cryengine5.6 low fps issue.

Posted: Fri Sep 06, 2019 4:41 pm
by Intrepid3D
I have the same problem only to a much worse extent, CVar Dump attached to the OP.

viewtopic.php?f=40&t=12086&p=25777#p25777

Re: cryengine5.6 low fps issue.

Posted: Fri Sep 06, 2019 4:44 pm
by Cry-Flare
Please take care not to create duplicate topics. The second thread will be closed, please direct related info to this thread.

Regarding the CVar dump, it is a suggestion to dump the CVars from both versions and compare them.

Re: cryengine5.6 low fps issue.

Posted: Fri Sep 06, 2019 5:05 pm
by Intrepid3D
The CVar Dump is huge, about 450KB, comparing them in Notepad++ shows a lot of differences between them, i wouldn't know where to start trying to figure it all out......

Where is the CVar and can i just copy the one from 5.5.2 to 5.6.1 to see if that fixes the performance issue?

5.5.2 CVar Dump attached, the one from 5.6.1 is in the now closed thread.

Re: cryengine5.6 low fps issue.

Posted: Fri Sep 06, 2019 6:23 pm
by noise
The same problem, I thought a known problem and in 5.6.1 will fix

Re: cryengine5.6 low fps issue.

Posted: Sat Sep 07, 2019 5:26 pm
by VascotiaStudios
Why on earth are you comparing medium spec on 5.5 to very high spec on 5.6 and then wonder why fps is different?

Re: cryengine5.6 low fps issue.

Posted: Sat Sep 07, 2019 5:47 pm
by noise
Why on earth are you comparing medium spec on 5.5 to very high spec on 5.6 and then wonder why fps is different?
viewtopic.php?f=40&t=12086&p=25777#p25777 Well, here are both versions HighSpec, but the difference in FPS is huge, there is a problem! No need to assume that all fools

Re: cryengine5.6 low fps issue.

Posted: Sat Sep 07, 2019 5:56 pm
by VascotiaStudios
Why on earth are you comparing medium spec on 5.5 to very high spec on 5.6 and then wonder why fps is different?
viewtopic.php?f=40&t=12086&p=25777#p25777 Well, here are both versions HighSpec, but the difference in FPS is huge, there is a problem! No need to assume that all fools
I didnt, i pointed out the first comparisons werent done right.

@op
Is anything being spammed to console? Any errors?

Re: cryengine5.6 low fps issue.

Posted: Sat Sep 07, 2019 8:14 pm
by Intrepid3D
They are both High Spec, The only difference between my two videos is the engine version.

5.5: 80 FPS
5.6 10 FPS. and look at the CPU usage in the 5.6 version, its about 90% across 12 threads.

Something in 5.6 is not right, those videos are just an example, if i make a brand new level in 5.6 with just a spawnpoint and nothing else the FPS are about 20 compared to well over 100 in 5.5.

@ noise what sort of FPS are you getting in 5.6 Woodland? what CPU / GPU are you running? i'm just wondering if there is a hardware comicality, perhaps something in the code doesn't like Ryzen 3000 series CPU's, who knows they have only been out a few weeks.