Page 3 of 3

Re: cryengine5.6 low fps issue.

Posted: Mon Sep 09, 2019 3:37 pm
by lavizh
Try running Woodlands cinematic flythrough on both 5.5.2 and 5.6.1 on highspec, then record lowest fps and highest fps, then calculate the average fps on both, like a proper benchmark should. Also take notice on actual MS per frame on both.

Re: cryengine5.6 low fps issue.

Posted: Mon Sep 09, 2019 5:27 pm
by Intrepid3D
5.5 Woodland Time Demo:
Average FPS: 82.74
Max FPS: 187.62
Min FPS: 24.06
==============================================================
TimeDemo Play Started ,Level=woodland (Total Frames: 14903, Recorded Time: 252.97s)
Run Finished.
Play Time: 180.11s, Average FPS: 82.74
Min FPS: 24.06 at frame 4138, Max FPS: 187.62 at frame 1
Average Tri/Sec: -9899000, Tri/Frame: -119634
Recorded/Played Tris ratio: 1.11
Memory Usage: WorkingSet=1306Mb, PageFile=3307Mb, PageFaults=906102
AutoTest Play Ended, (1 Runs Performed)
==============================================================

5.6 Woodland Time Demo:

This one looks different. i'll put it in a .zip because its huge... it has a lot of this

-Peak at Frame 1, 154.30ms : Wait - Physics Update (count: 1)
-Peak at Frame 1, 143.00ms : CSystem::DoFrame (count: 1)
-Peak at Frame 31, 332.77ms : Wait - StreamIO New Request (count: 1)
-Peak at Frame 50, 131.61ms : Wait - Network Wakeup (count: 1)

in it, one for each frame, 14900 of them.

Average FPS: 10.03
Max FPS: 16.77
Min FPS: 5.21

Edit: 154ms and 143ms is a long wait for whatever its waiting for, no wonder the FPS are so low, 150ms is equal to about 7 FPS. might that explain what's wrong here?

Re: cryengine5.6 low fps issue.

Posted: Mon Sep 09, 2019 5:56 pm
by lavizh
Is the resource compiler converting in the background?

Re: cryengine5.6 low fps issue.

Posted: Mon Sep 09, 2019 8:05 pm
by Intrepid3D
Is the resource compiler converting in the background?
I don't know, how would i check that? i can't see anything like that in the Task manager, the CPU load is usually high in game.

Image

Re: cryengine5.6 low fps issue.

Posted: Wed Sep 11, 2019 9:55 am
by Cry-Flare
We would like to investigate this issue to see what the cause is exactly.
Thank you for providing the CVar dumps.

I would ask that everyone with performance disparities please provide us with a DXDiag log and Editor.log.

Re: cryengine5.6 low fps issue.

Posted: Wed Sep 11, 2019 1:01 pm
by Intrepid3D
Thanks.

DxDiag and Editor.log attached.