Re: cryengine5.6 low fps issue.

#11
"Low FPS"? I'm running an older system (AMD FX 9590, 16GB DDR3, RX-580 8GB, and my FPS dropped from around 300 FPS (before vegetation) to around 250 but I assume it's limited to the Sandbox API (There is Vulkan/DX12 API support for Sandbox on the official "Roadmap" for 5.7 under "Graphics and Rendering". As you may or may not know, Your API could greatly affect performance and you are limited in Sandbox 5.6 to DX11 (I believe). Once you build it and run it as a game file you will have more options like Vilkan to render through that should be as good or better than 5.5.2. Best wishes
VR-SnowCrash
PC and Console Game/VR Developer
Virtual Revolution L.L.C.
www.vr-evolution.com

Re: cryengine5.6 low fps issue.

#12
"Low FPS"? I'm running an older system (AMD FX 9590, 16GB DDR3, RX-580 8GB, and my FPS dropped from around 300 FPS (before vegetation) to around 250 but I assume it's limited to the Sandbox API (There is Vulkan/DX12 API support for Sandbox on the official "Roadmap" for 5.7 under "Graphics and Rendering". As you may or may not know, Your API could greatly affect performance and you are limited in Sandbox 5.6 to DX11 (I believe). Once you build it and run it as a game file you will have more options like Vilkan to render through that should be as good or better than 5.5.2. Best wishes
With respect this isn't helping, you have an FX series CPU telling to use a different API if we are getting low FPS, ignoring the fact that we are seeing these performance drops just going from 5.5 to 5.6 and that performance drop in my case at least is MASSIVE... your CPU, again with respect isn't even half as fast as mine, its not a case of me needing to run a different API, i have 12 threads to your 8 and each one is literally twice as fast as yours.

All of this is distracting from the issue, that is 80 FPS in 5.5 vs 10 in 5.6 with the same computer, something is not right here.

Ryzen 3600. GTX 1070. 16GB DDR4. Windows 10 Pro.

5.6: 10 FPS


5.5 80 FPS

Re: cryengine5.6 low fps issue.

#13
"Low FPS"? I'm running an older system (AMD FX 9590, 16GB DDR3, RX-580 8GB, and my FPS dropped from around 300 FPS (before vegetation) to around 250 but I assume it's limited to the Sandbox API (There is Vulkan/DX12 API support for Sandbox on the official "Roadmap" for 5.7 under "Graphics and Rendering". As you may or may not know, Your API could greatly affect performance and you are limited in Sandbox 5.6 to DX11 (I believe). Once you build it and run it as a game file you will have more options like Vilkan to render through that should be as good or better than 5.5.2. Best wishes
With respect this isn't helping, you have an FX series CPU telling to use a different API if we are getting low FPS, ignoring the fact that we are seeing these performance drops just going from 5.5 to 5.6 and that performance drop in my case at least is MASSIVE... your CPU, again with respect isn't even half as fast as mine, its not a case of me needing to run a different API, i have 12 threads to your 8 and each one is literally twice as fast as yours.
All of this is distracting from the issue, that is 80 FPS in 5.5 vs 10 in 5.6 with the same computer, something is not right here.[/quote]

Ryzen 3600. GTX 1070. 16GB DDR4. Windows 10 Pro.[/quote]

Actually APIs like Vulkan leverage your hardware differently than DX including the CPU (obviously) which the CryEngine relies on more than your average 3d engine. The reference to my hardware was to show you my lower system specs and let you know I'm NOT getting the performance drop you are. In the future, you need to read the post before dismissing it. Your Ryzen isn't the problem obviously but the engine is working just fine on certain hardware. I don't know what part of irrelevant this information is?
VR-SnowCrash
PC and Console Game/VR Developer
Virtual Revolution L.L.C.
www.vr-evolution.com

Re: cryengine5.6 low fps issue.

#14
Why on earth are you comparing medium spec on 5.5 to very high spec on 5.6 and then wonder why fps is different?
viewtopic.php?f=40&t=12086&p=25777#p25777 Well, here are both versions HighSpec, but the difference in FPS is huge, there is a problem! No need to assume that all fools
I didnt, i pointed out the first comparisons werent done right.

@op
Is anything being spammed to console? Any errors?
Same problem here.

Put same level into difference version cryengine has difference fps.

Actually, FPS, 5.4 is also lower than 5.5. Not just in CE5.6 has this problem.

Please take this problem seriously. :(

Re: cryengine5.6 low fps issue.

#15
8K x 8K Terrain Size, 16K Terrain Texture, procedural vegetation. This is "why" I responded. I was referring to this FPS difference. The difference between the Sandbox emulation and the actual game engine. These are all in DX11 and look at the FPS. I only mentioned my situation to help you narrow down yours. Why is my much less powerful computer having little to no issue throwing almost 100 FPS at me on very High settings @1080p? I'm sure it will be figured out if some of us don't have the problem but communicating our hardware specs and the situations under which these problems occur is paramount to fixing it.

https://drive.google.com/open?id=1VX_sf ... XfCNYTm1nB

https://drive.google.com/open?id=16u8wD ... YkgLDobt7m

https://drive.google.com/open?id=1-K5NN ... 6pTcisYZYv

https://drive.google.com/open?id=1jAvyv ... q2IGOacOqg
5_6_test1.jpg
5_6_test1.jpg (685.26 KiB) Viewed 1502 times
5_6_ingame_test2.jpg
5_6_ingame_test2.jpg (580.13 KiB) Viewed 1502 times
5_6_ingame_test1.jpg
5_6_ingame_test1.jpg (577.33 KiB) Viewed 1502 times
Best Regards
VR-SnowCrash
PC and Console Game/VR Developer
Virtual Revolution L.L.C.
www.vr-evolution.com

Re: cryengine5.6 low fps issue.

#16
8K x 8K Terrain Size, 16K Terrain Texture, procedural vegetation. This is "why" I responded. I was referring to this FPS difference. The difference between the Sandbox emulation and the actual game engine. These are all in DX11 and look at the FPS. I only mentioned my situation to help you narrow down yours. Why is my much less powerful computer having little to no issue throwing almost 100 FPS at me on very High settings @1080p? I'm sure it will be figured out if some of us don't have the problem but communicating our hardware specs and the situations under which these problems occur is paramount to fixing it.

https://drive.google.com/open?id=1VX_sf ... XfCNYTm1nB

https://drive.google.com/open?id=16u8wD ... YkgLDobt7m

https://drive.google.com/open?id=1-K5NN ... 6pTcisYZYv

https://drive.google.com/open?id=1jAvyv ... q2IGOacOqg

5_6_test1.jpg

5_6_ingame_test2.jpg

5_6_ingame_test1.jpg

Best Regards
You should compare 5.5 and 5.6 with the same LEVEL. Besides, polygon in your LEVEL is not enough. (You can using woodland to compare FPS) :)

Re: cryengine5.6 low fps issue.

#20
You should compare 5.5 and 5.6 with the same LEVEL. Besides, polygon in your LEVEL is not enough. (You can using woodland to compare FPS) :)
[/quote]

This project was mostly built on 5.5 so we've seen the drop in FPS. As a matter of fact, it was shown in my post. lol :P There is only vegetation in that test map I threw together but it's also 67 KM2 and using 16Kx16K terrain textures. I was getting about 50 FPS higher on 5.5. ;)
VR-SnowCrash
PC and Console Game/VR Developer
Virtual Revolution L.L.C.
www.vr-evolution.com

Who is online

Users browsing this forum: No registered users and 5 guests