how to avoid show the edge of shadow

#1
i wanna increase the distance of shadows,and i adjust some var in console(e_gsmrange=15,e_gsmrangestep=3)
but it shows a obvious shadows square,it looks not good.........how can i make it more smoothly????
qq3.png
qq3.png (1.63 MiB) Viewed 1506 times
qq4.png
qq4.png (4.73 MiB) Viewed 1497 times
in cryengine 3.5,the shadows square has a transition region on the edge,it looks more smooth than the new version

Re: how to avoid show the edge of shadow

#2
Hi there,

It may require more tweaking of the GSM and shadow settings.
Can you use the gsm debug cvar and show us the result?

The CVar I mean is called "e_ShadowsCascadesDebug"
and also the `e_GsmStats 1` cvar.

A short movie clip would be best to show the setup.
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 1 guest