Level corrupted...again!

#1
hi,
I'm working with 5.4 and it's happening a lot of times that when I save a level and then I reopen it, I get this error:

[Assert] Condition: nStrLen <= 100000 [line 170] [File=d:\jk\gamesdk_release\code\cryengine\crysystem\SimpleStringPool.h]
[Warning] XML reader: not well-formed (invalid token) at line 5898 (thealiencube/levels/l1-2_intermedio_v99\Layers/Main.lyr)
[Error] Failed to import layer file 'thealiencube/levels/l1-2_intermedio_v99\Layers/Main.lyr'

The Main layer results corrupted, so hours of hard work are lost.
This is happening so often that I'm going crazy.

Is there any way to avoid this problem?

Re: Level corrupted...again!

#3
If i remember correctly there were layer issues with 5.4, i could be wrong though.

Did you save the level in an unstable editor event? That will also corrupt the level.
Never saved with an unstable event.
Do you know if there is a way to limit this problem?

Re: Level corrupted...again!

#4
Without knowing the cause of the issue we cannot provide advice for prevent it.
The assert mentioned that the size of the file is huge, and is usually the case when you have complex or an abundance of Designer objects in that layer.

If a layer file is corrupted, it is usually a sign of malformed XML. The layer files are made up of XML elements.
If you can provide the layer file in a zip file, we could analyze it and find where the malformed XML has been broken and may provide insight into what is happening.
Uniflare
CRYENGINE Technical Community Manager
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 6 guests