Advanced Animation Component Reset Problem

#1
Hey all.

I am having quite a hard time with Advanced Animations component.
Whenever I do:

A-) "Launch Game" with that project
B-) From Sandbox Debug->Reload All Scripts

I get this. For some reason whenever I do something that causes to reload entities or scripts I get this results. Whether in editor or game

Image

Image



Settings for component here. There isn't anything in Signal or Construction Graphs. The character is directly taken form 3rd Person Shooter Template.

Image



I checked a lot of things to make sure that if it is something I caused from somewhere else. But so far none.

Any ideas ?

Thanks.

Re: Advanced Animation Component Reset Problem

#3
I am trying to understand what Crytek meant by utilizing this component since there is no detailed documentation for Schematyc. I wanted to use whatever existing here before writing some code.
Sure there is the 3rdPersonShooter template. If I don't get an answer by tomorrow I guess I'll write an Component by using the code from that template.

Re: Advanced Animation Component Reset Problem

#4
Sorry for double post but how to say... This ought to be a very simple stuff to answer. If it is broken just say it is. I am understanding in that a new release has new bugs, but can I at least get an answer please ?
I mean to say in the kindest manner: I am losing quuiiite a bit of time figuring stuff this simple; because I don't understand Crytek's aim of putting Advanced Animation Component there and not giving an explanation in the docs. For some reason "Question" website isn't working in Turkey (page can not be found) so that is also a no go.

Thank you very much and Best of Regards.

Re: Advanced Animation Component Reset Problem

#6


You probably made a mistake by leaving the links here. It's good that you program in C ++, but you have to understand that Schematyc was not done so that a person every time that does not own C ++ climbed into a textbook or to Youtube in order to solve the task. For your videos there is a special section on the forum. If you can not advise a solution to the problem solely within the Schematyc tool, please do not copy your links again.

Re: Advanced Animation Component Reset Problem

#7
Hi there,

Schematyc is being improved currently and we are actively working on improving documentation.
There is a similar thread with resolutions to your issues here: viewtopic.php?f=14&t=4231

Perhaps this will shed some light on your problems.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 1 guest

cron