Generated AI Navigation Area Is not Saved When I Re-Open Level

#1
Hi Guys,

I've recently started creating large navigation areas on my map. Its my first time doing so in CEV, but in CE3 I've done this many times with no issues.

Like always it takes a while to generate, but once it does my characters are moving around fine.

HOWEVER, when I save the level, close out, and open it again my characters are no longer able to move at all. When I go to display the mesh it appears to be completely gone, and the continuous update is starting from scratch (which takes 8+ hours given the size of the navigation area I'm using)

I've tested with smaller navigation areas and it still occurs where characters can no longer move and the navigation area is being made from start all over again.

Anyone know why it is no longer saving the generated Navigation Mesh? I never had this issue in CE3. I am currently using CE 5.3 for this level FYI

Thanks for any help!

-Andrew

Re: Generated AI Navigation Area Is not Saved When I Re-Open Level

#3
You've already found one of problems that it is not about the size of area.
It's about the reopening level. There are a few ways of reopening a level. You can reload the level, or unload and start the same level again instead.
Try all of them. To reload your level, you can use flow graph node. Look for something like "UI:Functions:Game:ReloadLevel" in flow graph.
Whether the same thing happens in that way or not, (in any case!)activate debug agent type (for ex: "MediumSizedCharacters") then try to see if it's about the navigation area.
If at the first time blue and red areas(depending on your navigation properties[btw, red areas are forbidden for an ai) appears, that decreases possibility of its being navigation area bug.
It can be about something else rather than being about navigation area. But if it does not show, that means it's about loading navigation area again.
And don't forget to check your ai and ai properties.

(i don't know if i did many grammatical mistakes... if i did , i'm sorry and let me know :D i'm not that good at English btw)

Re: Generated AI Navigation Area Is not Saved When I Re-Open Level

#4
Hello,

There is an option in Edit -> Preferences... -> AI -> Navigation.
It's called Disable Navigation Regeneration on Level Load.

Unchecking this means the navigation will be automatically generated on level load, and the AI will behave properly.

When this is checked, the nav areas don't get generated on level load, which causes the behavior you described.

This worked for me.
Let me know if this helped!

Who is online

Users browsing this forum: No registered users and 1 guest