Page 1 of 1

Blurry materials

Posted: Sun Apr 15, 2018 1:29 pm
by thehankinator
Hi, I decided to give Cryengine a go but I can't get around this issue with materials (please see attached screenshot). I've am using engine version 5.4(latest stable version right?) with the C++ FPS project. I have not changed a single thing. I don't know what I am doing wrong. Every model I try to import in has the exact same problem. I've tried verifying the engine and re-downloading the engine. I also recreated the project about 10 times. I've attached a screenshot of the problem. I also get warnings when I open the editor "XML reader: Can't open file (assets\animations\mannequin\preview\sdk_playerpreview1p.xml)". Are these warnings normal? I didn't change or do anything other than create and open the project. Any ideas? Thanks!

Re: Blurry materials

Posted: Sun Apr 15, 2018 2:48 pm
by lavizh
Do they look blurry in the Viewport too? Ignore the material preview in the Material Editor. That thing hasn't worked right in years. I always use the viewport to check textures. Best preview there is.

Re: Blurry materials

Posted: Sun Apr 15, 2018 7:21 pm
by thehankinator
Do they look blurry in the Viewport too? Ignore the material preview in the Material Editor. That thing hasn't worked right in years. I always use the viewport to check textures. Best preview there is.
I didn't try dropping them into the viewport. Of course I had rebooted restarted redownloaded many times before but this time the material viewer looks correct now and I didn't do anything! I'll use the viewport to confirm materials from now on. Thanks!

Re: Blurry materials

Posted: Sun Apr 15, 2018 8:46 pm
by lavizh
Dont drop them in there, just use the viewport as your material preview. put your mesh in and check.