Re: Cant find no Terrain Texture?

#2
Has a .cryasset file been created by the Resource Compiler? If not that is your reason. Rightclick on .cryproject file in your Project folder (not where the engine is installed) and click Generate Metadata. If you'd like to disable the Asset Browser you can always put the following cvar into editor.cfg where the engine is installed (not your project folder).

I don't like using the current Asset Browser either, nor do i like the .cryasset format, hinders my workflow, so i always disable the Asset browser.

Code: Select all

ed_enableAssetPickers = 0

Re: Cant find no Terrain Texture?

#8
Hi NightWolf,

It looks like you are trying to find a Material when you need to be looking for a texture.
First you will want to create your material using the Material Editor Dialog. (Tools->Material Editor Legacy)
Make sure to set the shader type to Terrain.Layer, and then assign your texture in the diffuse slot.

Create a new Material:
new_material.png
new_material.png (35.02 KiB) Viewed 700 times
Setup your terrain material:
1: Set the shader type to Terrain.Layer.
2: Set the diffuse texture to your terrain texture you copied over. (Check below if you cannot see it).
3: Save the material.
set_save_material.png
set_save_material.png (56.1 KiB) Viewed 700 times
Now when trying to find the material as you were before, you should find your material that you just created rather than the original texture.

----

If you are having trouble finding the terrain texture when setting the diffuse in your terrain material then as Lavizh mentioned you have two options:
1. Regenerating meta-data
a. First, make sure to delete all .cryasaet files inside the folder you are having trouble with (in this case I assume the terrain folder).
b. Launch the editor, if you still cannot see your terrain folder in the picker dialog, click Regenrate Meta-Data in the Asset Browser like so:
regen_metadata.png
regen_metadata.png (15.84 KiB) Viewed 700 times
You can find the Asset Browser by going to Tools->Asset Browser

2. Disabling the Asset Browser Picker
a. Type the command 'ed_enableAssetPickers 0' into the console window like so:
disable_assetpicker.png
disable_assetpicker.png (11.87 KiB) Viewed 700 times
Let us know if you still have issues.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 1 guest