Re: Ocean doam settings in Cryengine 5?

#32
drag a empty entity. add mesh component. set mesh of the component. set mass or density of the mesh component. put entity on ocean. if not work, change mesh. then parent your boat under the previous entity.
I do believe I've done that, I can't get physics to work at all, not just with my boat. I could get balls a whatnot to float in 5.3, so feel very confused right now. I click 'Enable Physics/AI' to start the simulation, correct?

So my steps:

1. in Create Object, select Empty Entity. Click into scene to create entity.
2. In the objects Properties, click Add Component>Mesh
3. Under Transform>File load in my boat (or anything like a cube or a ball from the Cryengine objects).
4. Set Mesh?Physics Settings>Density to 500.
5. Clinch 'play: Enable Physics/AI' icon
6. Nothing happens.

Re: Ocean doam settings in Cryengine 5?

#36
put ball in the air. does it fall down?
Nope.
Does the ball have a proper physics Proxy?
I honestly don't know. I have tried using Components>Geometry>Mesh, Static Mesh Entity>Objects>Default>Primitive_box.cfg

How do I set up a proper physics proxy? I though the point of using 5.4 was that was no longer needed/different behavior. As I said, I can get stuff to float in 5.3, just couldn't link my boat to follow the motion. I can't get anything floating in 5.4.

Re: Ocean doam settings in Cryengine 5?

#38
Ok, I don't have 3DSMax so didn't do that part, but following what else you posted I was able to get the boat to float and bounce around. It is still not pretty but it is progress. I can't scale the box collider though, so it is like the boat is resting on a pin.

I use Blender, have CryBlend installed, but again, I'm confused, my attempts to add physics proxies there haven't worked either. Thank you very much for your help though, I'll keep messing with it and see what I can get done.

Who is online

Users browsing this forum: No registered users and 1 guest