Re: can't access animation in anim list

#2
Hi Guys!

I'm using Ryse Legionnaire to test character animation, the problem in character tool I can play any animation but i want put into level to test animation with the flow graph, I can't see any animation list in here
How I can fix ?

https://drive.google.com/open?id=1nOqXM ... PZfm3oSABA

Thanks
You can use the playanimation node to test the anim. Create new flowgraph add a start node connect it to the playanimation, assign the character entity to that node and choose the animation
Image

Re: can't access animation in anim list

#3
As you see, animation input type is String. Triple "."/choose button is for making finding animation name easier. So, if you even write animation's name there manually, it'll get and play the animation.
As for why it does not pop up character's animation list, it's because you should assign selected entity directly without an entity id node. Despite this, if you still want to use entity id node, after assigning your entity to animation node and choosing your animation name, you can connect your entity id node to animation id input.
That's what you need.

Have a nice one!

Re: can't access animation in anim list

#4
Hi there,

If you are using GameSDK you will want to use the Legacy Entity "MannequinEntity", select your CDF for the legionaire and do as you already have, the animations should appear.
If you still have trouble try regenerating Asset Meta Data.
Uniflare
CRYENGINE Community Coordinator
Here to help the community and social channels grow and thrive.

My personal belongings;
Beginner Guides | My GitHub | Splash Plugin

Who is online

Users browsing this forum: No registered users and 2 guests