No sound with SDL MIxer

#1
Hi guys,

I have some problems with sounds in CryEngine 5.4.
I use the SDL Mixer and I would like to import my own sounds.
But I can´t hear any sound.

1. I enable the SDL MIxer (s_AudioImplName = CryAudioImplSDLMixer)
2. I create a simple bird sound and export it in REAPER with the following settings:

Output format: WAV
Sample rate: 48000Hz
Channels: Stereo
WAV bit deph: 16 bit PCM

3. Then I copy the .wav file to "C:\Program Files (x86)\Crytek\CRYENGINE Launcher\Crytek\gamesdk_5.4\GameSDK\GameSDK\audio\audio\sdlmixer"
4. I open the Audio Controls Editor and create a new library "Birds".
5. I connect "birds.wav" with the library.
6. I save the settings.

But I hear nothing when I press spacebar or "Execute Trigger"
Same problem with the Audio Trigger Spot.

What I tried too:

1. I exported an .ogg file but there is no sound too.
2. I exported .wav and ogg. files with different settings (bit and kHZ ) but nothing worked.

Here is my System:
Microsoft Windows 10 Pro
Intel(R) Core(TM) i7-7700
NVIDIA Quadro M4000
16GB RAM

I hope you can help me
(Sorry for my bad English)

Re: No sound with SDL MIxer

#3
Hi,
The double GameSDK in the path is actually correct in your case. However, the double audio folder isn't.
What you want is:
...\CRYENGINE Launcher\Crytek\gamesdk_5.4\GameSDK\GameSDK\audio\sdlmixer
From there on you can create any sub-folder-structure that you like. So this will work even though it looks ill formed:
...\CRYENGINE Launcher\Crytek\gamesdk_5.4\GameSDK\GameSDK\audio\sdlmixer\audio

Who is online

Users browsing this forum: No registered users and 1 guest

cron