SDL Mixer no sound in game

#1
I use SDL Mixer as audio middleware. In the sandbox editor and in its game mode everything works fine but in the released game there is no sound at all. When I use Wwise, it works but as my sound setup is very simple, I would prefer to use SDL Mixer. What could be the problem?

Re: SDL Mixer no sound in game

#2
Can you share a bit more data with us?
Which build do you use? Is it maybe custom built off of GitHub?
How exactly do you set SDL_mixer as a middleware?
Can you confirm that SDL_mixer is really running in the released game?
If so where does it look for audio data and is the data indeed present?

Re: SDL Mixer no sound in game

#3
I use the the 5.3 build that I downloaded from the launcher, so no custom build.
I added 's_AudioImplName = CryAudioImplSDLMixer' to the system.cfg in the engine's root folder. But if I understood it right, the SDL Mixer is the default option, right?
How do I check whether SDL Mixer is running in the released game? If it doesn't what can I do?
The audio files are in the Assets\audio\sdlmixer folder of my project and they are arranged in the sandbox editor and work fine in there. When I start game mode from the editor it still works but not in the released game.

Re: SDL Mixer no sound in game

#4
tschaens93 wrote:I use the the 5.3 build that I downloaded from the launcher, so no custom build.
I added 's_AudioImplName = CryAudioImplSDLMixer' to the system.cfg in the engine's root folder. But if I understood it right, the SDL Mixer is the default option, right?
How do I check whether SDL Mixer is running in the released game? If it doesn't what can I do?
The audio files are in the Assets\audio\sdlmixer folder of my project and they are arranged in the sandbox editor and work fine in there. When I start game mode from the editor it still works but not in the released game.

You using Release Mode for game launcher testing? Are the audio files located in PAK files? That is required for Release Mode.

Re: SDL Mixer no sound in game

#7
cry-miron wrote:You're probably missing the smpeg2.dll in your bin folder. By default cry-patsy's script filters out files that start with smpeg2 here. I'm not sure if that's intended, but you can easily fix it by removing that line or manually copying smpeg2.dll to your packaged build.


That was exactly the problem. Removing the line from the script solved it. Thank you very much!

Who is online

Users browsing this forum: No registered users and 1 guest