Properly importing

#1
Hello everyone,

coming from a programming background I've just made my first steps with blender. I have made some low poly models and now want to marvel at my creation inside cryengine.
I UV unwrapped the models, painted them with surface painter and imported it all into cryengine. Now I have two weird problems, both of which are probably a result of my wrong importing:

First I have some weird shadows on my faces:
Image

they have a blank normal map, and an all green/ all brown diffuse map. Since they are meant to look low poly, there shouldn't be any other maps should there?
The lighting settings are the standard 5.5 preview 1 settings, I just made a new project and imported the mesh and made a new multi material

Then, what is even more weird, when I unfocus the tree, this happens:
Image
The base tree and the leaves are seperate objects in blender, but why does it matter to cryengine, and why exactly are they only dropping when unfocused?

Re: Properly importing

#2
Hi!

The black faces are due to the GI being turned off, you should also select the environment probe and generate cubemaps. To turn GI on by going inside the edit - preferences - lighting -general menu and making sure the total illumination box is ticked on. Then click the level settings tab and if you scroll down you'll see the Total Illumination V2 category, tick the "active box". Just below the checkbox you should set the integration mode to 1.

About your second issue, I'm not sure about what's happening. Are your leaves combined to your branches? did you import the asset with CE's FBX importer (it's way better than using the export plugins inside maya,/3ds max/blender imo, the plugins were useful back when CE didn't support the FBX format ).

And your mesh is very glossy (which is normal when importing an asset with only a diffuse map). In the material editor, play around with the smoothness bar to make your tree rougher.

Re: Properly importing

#3
Thank you very much @ferdinanddemedicis!
The sheer number of lighting settings was really frightening, I would've never found this on my own.
The tree now looks a lot better. The issue with the leaves is probably fixable by combining the two objects in blender. It's just really weird why they fall down only when unfocused :D

The only issue left now is this:

Image

those thin, vertical black lines running through some of the faces. Any idea why this happens?

Maybe this is why you recommended me to add an environment probe, unfortunately sandbox crashes silently on me whenever I try to add an environment probe.
I might try it out in 5.4 to see if it solves this.

Re: Properly importing

#5
Yeah, that's what I thought first, too. But there are no doubled faces in the model itself, I checked.
What do you mean with LOD?
These are my input settings, I'm sorry about the blurriness:
Image

I'm not quite sure what LOD stands for and what it does.
I've played around with the settings, but I can't get rid of those vertical stripes.
It's not a material problem either, because you can see them with the default material as well.

Someone any ideas how to get rid of the stripes?

Re: Properly importing

#6
LOD means Level of Detail. Basically, when you're creating a model, you must duplicate it and reduce it's polycount to a certain degree. Then, duplicate this lod and reduce it's polycount a bit more. I usually create 3 LODs. As you move away from the mesh, your higher poly mesh will be replaced by the lower poly ones, saving lots of memory.

So let's say you have a chair model. The normal model (LOD0) has something like 2000 polys. Duplicate it, and reduce it's polycount (there's a modifier in blender for that, I think it's called decimate) so that it gives you something like 1500/1200 polygons (the first lod is the closest one, it should not look too low res). Then duplicate your first lod and reduce it's polycount down to 700-800. You can create up to 5 or 6 lods in cryengine. In blender, create a group with your mesh, the LODs and a proxy (for collisions. Just duplicate your mesh, reduce it's polycount as low as you can while preserving the object's main shape. Add a blank material for the proxy) and export the group as a FBX. Then, refer to this video to setup your mesh in the FBX importer.

https://www.youtube.com/watch?v=o4vpWF58qIE

About your issue with your model, you could try to clean up the mesh inside blender, there are options for that inside the software. If that doesn't work you can send me the model in PM, I'll see what I can do to fix it. :)

Re: Properly importing

#7
Thank you for the explanation, that makes perfect sense now!
I don't think though, I'll need different LOD's in my case since I'm aiming for a low poly art style.
Oh and also for the tip with the physics proxy, I always thought I'd have to define one inside CE, but using blender for that should be much easier :)

I have sent you a PM, thank you very much for your help, mate

Who is online

Users browsing this forum: No registered users and 1 guest