Page 1 of 4

Not having , some shaders

Posted: Sun Jun 03, 2018 1:58 pm
by Hamedudk
Hi.
These shaders do not exist:

Scopes Shader (It is important.)
CloakLayer Shader
Hologram Shader
LensOptics.Enable Shader
Monitor Shader
NoDraw Shader
ParticleImposter Shader
Ping Shader
Sky Shader
SkyHDR Shader

CryEngine V
http://docs.cryengine.com/pages/viewpag ... d=26215199

Re: Not having , some shaders

Posted: Sun Jun 03, 2018 5:09 pm
by lavizh
Most of them are obsolete with CRYENGINE 5. Some were even specific to Crysis, hence why they were removed. NoDraw is available via Illum, Sky Shader should still be there. Thankfully shadercode is available. Perhaps find someone who can help you? That page needs to be updated. Will alert them.

Re: Not having , some shaders

Posted: Wed Jun 06, 2018 8:07 am
by Hamedudk
Most of them are obsolete with CRYENGINE 5. Some were even specific to Crysis, hence why they were removed. NoDraw is available via Illum, Sky Shader should still be there. Thankfully shadercode is available. Perhaps find someone who can help you? That page needs to be updated. Will alert them.
My main problem is Shaders Scopes
However, I hope
in the new version, Shaders will update.

Re: Not having , some shaders

Posted: Wed Jun 06, 2018 8:26 am
by lavizh
Yeah but thats a Crysis specific Shader and it isn't coming back.

Re: Not having , some shaders

Posted: Thu Jun 07, 2018 2:45 pm
by Hamedudk
Yeah but thats a Crysis specific Shader and it isn't coming back.
Scopes Shader has problems with gamesdk.
Image
Unfortunately, game sdk has a lot of errors.
Scopes Shader is very important for game sdk :(
However, in the new version of Scopes Shader? :cry:

Re: Not having , some shaders

Posted: Thu Jun 07, 2018 3:19 pm
by lavizh
There is no new version of the Scope Shader from Crytek. Its not coming back. You can search for a Shader programmer and hire him or her for the job though.

Re: Not having , some shaders

Posted: Fri Jun 08, 2018 1:56 pm
by noise
There is no new version of the Scope Shader from Crytek. Its not coming back. You can search for a Shader programmer and hire him or her for the job though.
Nonsense! How can the shader become obsolete !? Perhaps some part of the shader code may become obsolete! But the shader function itself can become obsolete!
The shader (Hologram) was removed, the shader created a controlled fresnel effect. When the Fresnel effect was out of date, I missed something! Strange policy at Crytek, the branch of shaders in general ceased to develop. It's time for them to think about a new Material Editor.
Nobody in this community will hire a programmer to write shaders, this is nonsense! When there is a UE4 with its super-duper powerful Material Editor. Even in Unity began to import a new nodal, flexible material editor. And Crytek was stuck in 2007, there and remains!

Re: Not having , some shaders

Posted: Fri Jun 08, 2018 2:09 pm
by lavizh
It was Crysis specific shaders. Not CRYENGINE 5 related.

Re: Not having , some shaders

Posted: Fri Jun 08, 2018 2:29 pm
by noise
It was Crysis specific shaders. Not CRYENGINE 5 related.
This shader in the engine for 10 years! What is in CRYENGINE 5 such, except for a bunch of new bugs? that Crytek took and removed such a necessary shader? What prevents Crytek leave this shader and adopt it under CRYENGINE 5?

Re: Not having , some shaders

Posted: Sat Jun 09, 2018 6:43 am
by noise
Animated Textures also does not work !? I can not get to work! seriously what happens, why Crytek gets rid of the already insignificant functions of materials. In this MaterialEditor, soon one Illum shader will remain.
Can Crytek still make a new MaterialEditor? because the meaning is so restrict the already limited old MaterialEditor!
http://docs.cryengine.com/display/SDKDO ... d+Textures