Can't connect to dedicated server

Here's what I need to do:

I want to connect to a dedicated server with the Internet Ip.

The dedicated server and the Client are both running on my PC.

Steps that I've done:

1. Started Dedicated Server.
2. When fully loaded, I've entered these:

sv_bind @myInternetIP
sv_port 64090
map forest s

(P.S I've tried many CryEngine versions I've collected over the years to get multiplayer working. This one I'm using is 3.4.5, as I've heard from many people while lurking the forum
this release had a stable multiplayer and there's no need to manage game sessions with steam, like in the next versions)
3. After Dedicated server finished loading, I've started the game client

4. Hit Multiplayer-->Join Server-->reached the Internet Lobby (i tried with LAN also)

5. When in the lobby, I hit "connect @myInternetIP:64090" (I tried both "connect @myInternetIP:64090" and "connect @myInternetIP 64090" and even "connect @myInternetIP")

5.1. Btw, I have disabled Firewall and opened TCP ports 64087, 64088, 64089, 64090, 64091 on Firewall, and even on the Router.

6. However, despited I've done all the recommendations I saw over the forums, I still get this error when I try to connect:

Code: Select all

[CONSOLE] Executing console command 'connect' Ending game context... [CBreakReplicator] Inaccurate world pos using range 0-10000.000000 with 13 bits [CBreakReplicator] Accurate world pos using range 0-10000.000000 with 21 bits Loading Config file multiplayer.cfg (game\config\multiplayer.cfg) Server controlled CVar: sv_bandwidth Server controlled CVar: g_hitDeathReactions_streaming Server controlled CVar: g_distanceForceNoIk Server controlled CVar: g_distanceForceNoLegRaycasts Server controlled CVar: net_packetsendrate Server controlled CVar: net_enable_tfrc Server controlled CVar: net_breakage_sync_entities Server controlled CVar: e_StreamCgfPoolSize Server controlled CVar: cl_AISystem Server controlled CVar: co_usenewcoopanimsystem Server controlled CVar: aim_assistMaxDistance Server controlled CVar: g_breakageMinAxisInertia Server controlled CVar: g_glassAutoShatterMinArea Server controlled CVar: s_ObstructionMaxPierecability Server controlled CVar: g_playerLowHealthThreshold Server controlled CVar: p_max_entity_cells Server controlled CVar: br_breakmaxworldsize [net 11:25:33.657] connection requested to: <session>-1, [net 11:25:33.657] resolved as: [net 11:25:33.657] There is no GameSpy service available [Warning] [net 11:25:36.467] Retrying connection to (10) [Warning] [net 11:25:39.751] Retrying connection to (20) [Warning] [net 11:25:42.943] Retrying connection to (30) [Warning] [net 11:25:46.165] Retrying connection to (40) [Warning] [net 11:25:49.345] Retrying connection to (50) [Warning] [net 11:25:52.405] Retrying connection to (60) [Warning] [net 11:25:55.559] Retrying connection to (70) [Warning] [net 11:25:58.821] Retrying connection to (80) [Warning] [net 11:26:01.823] Retrying connection to (90) [Warning] [net 11:26:03.703] Connection to timed out
It seems like the client knows where to connect, but something is blocking a connection. This is really strange because I have opened ports and disabled firewalls
Am I missing something important?

Who is online

Users browsing this forum: No registered users and 1 guest