Page 1 of 1

Problems with Rolling ball template

Posted: Sat Aug 10, 2019 7:43 am
by johntrsh
Hey im trying the template " Rolling Ball" multiplayer. I run dedicated server and connected 2 clients. Is working, but flickers and flashes like hell. The ball changing positions to old ones at some frame rates. Is this a known problem? Engine 5.5.2, windows 10 x64

https://streamable.com/keofr

Haven't changed code. Without networking it works fine.

Re: Problems with Rolling ball template

Posted: Sun Aug 11, 2019 1:37 pm
by mknmknmknjk
Rolling Ball is not designed for multiple play. so it will not be functional .

Re: Problems with Rolling ball template

Posted: Mon Aug 12, 2019 7:08 pm
by johntrsh
Rolling Ball is not designed for multiple play. so it will not be functional .
Well it has MP functionality and I was directed to check it from Discord talk.

Re: Problems with Rolling ball template

Posted: Mon Aug 12, 2019 8:57 pm
by personwithhat2
Known issues. Plus spamming space == you can jump infinitely.

It's not a good sample, and until CE updates it/adds new ones........

If you have any network questions you can post a Q on the forums and I'll try to help. I'm working extensively on my own network template anyways .-.

Re: Problems with Rolling ball template

Posted: Tue Aug 13, 2019 2:12 am
by mknmknmknjk
in player.cpp

line 306 i think should be

Code: Select all

if (pressedKeys == 0) { HandleInputFlagChange(changedKeys, eIS_Pressed); } const TInputFlags releasedKeys = changedKeys & prevInputFlags; if (releasedKeys != 0) { HandleInputFlagChange(pressedKeys, eIS_Released); }
if (ser.IsReading()) is redundant ,since m_inputFlags is already synced on server and other clients.