(SOLVED) Hit Reactions System dont playing my anim ?

#1
hey,

like said in doc :
http://docs.cryengine.com/display/SDKDOC4/Hit+and+Death+Reactions+System
and http://docs.cryengine.com/display/SDKDOC4/Reactions+XML+Format+Description

i try to play an animation on hit with the simple code:

Code: Select all

<DeathHitReactionsParams>
   <HitReactionParam>
      <ReactionAnim>
           <AnimNames>
             <AnimName name="my_hit_anim"/>
          </AnimNames>
      </ReactionAnim>
   </HitReactionParam>
</DeathHitReactionsParams>


but the animation in not played when i hit the AI.

Is this system still working ? or is it any trick to use it ?
Last edited by manuk on Sat May 20, 2017 1:30 pm, edited 1 time in total.
ManuKor
www.HeathenGame.com
Image

Re: Hit Reactions System dont playing my anim ?

#3
i know how to play a fragment from the hitdeaths xml, but that not what im asking. ^^

in the doc, it say we can call directly an anim from the hitdeaths XML.
Example is the doc: ( http://docs.cryengine.com/display/SDKDOC4/Reactions+XML+Format+Description )

Code: Select all

<HitReactionParam>
  <ReactionAnim additive="1" layer="5">
    <AnimNames>
      <AnimName name="stand_tac_hitBelly_rifle_add_3p_01"/>
      <AnimName name="stand_tac_hitShoulder_rifle_add_3p_01"/>
      <AnimName name="stand_tac_hitShoulderHMG_rifle_add_3p_0" variants="3"/>
      <!-- variants="3" above is equivalent to:
      <AnimName name="stand_tac_hitShoulderHMG_rifle_add_3p_01"/>
      <AnimName name="stand_tac_hitShoulderHMG_rifle_add_3p_02"/>
      <AnimName name="stand_tac_hitShoulderHMG_rifle_add_3p_03"/>
      -->
    </AnimNames>
  </ReactionAnim>
</HitReactionParam>


this should calling directly anims from xml without any fragments in mannequin, no ?

so my question is: is this system still working ? ( calling anims from the xml, without mannequin )
or is it depreciated ?
ManuKor
www.HeathenGame.com
Image

Re: Hit Reactions System dont playing my anim ?

#5
nevermind i was missing some parameters.

this example working:

Code: Select all


   <HitReactionParams>   
      <HitReactionParam>
         <ReactionAnim additive="0" layer="5">
            <AnimNames>
              <AnimName name="relaxed_tac_idle_reactping_rifle_3p_02"/>
            </AnimNames>
         </ReactionAnim>
      </HitReactionParam>      
   </HitReactionParams>



the parameters "additive" and "layer" were missing.

Ty anyway for trying to help.
ManuKor
www.HeathenGame.com
Image

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest